aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-FormValidator-Simple/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Catalyst-Plugin-FormValidator-Simple/Makefile')
-rw-r--r--www/p5-Catalyst-Plugin-FormValidator-Simple/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-FormValidator-Simple/Makefile b/www/p5-Catalyst-Plugin-FormValidator-Simple/Makefile
new file mode 100644
index 000000000000..3367d61c2444
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-FormValidator-Simple/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-FormValidator-Simple
+# Date created: 21 Nov 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-FormValidator-Simple
+PORTVERSION= 0.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/L/LY/LYOKATO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Validator for Catalyst with FormValidator::Simple
+
+BUILD_DEPENDS= p5-Catalyst>=5.30:${PORTSDIR}/www/p5-Catalyst \
+ p5-Catalyst-Plugin-FormValidator>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-FormValidator \
+ p5-FormValidator-Simple>=0:${PORTSDIR}/textproc/p5-FormValidator-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::FormValidator::Simple.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500800
+IGNORE= requires Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>