aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Session-Store-DBI
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-Store-DBI')
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-DBI/Makefile33
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-DBI/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-DBI/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-DBI/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-Store-DBI/Makefile b/www/p5-Catalyst-Plugin-Session-Store-DBI/Makefile
new file mode 100644
index 000000000000..a1ed2e8b40ef
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-DBI/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-DBI
+# Date created: 2 Jan 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-DBI
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Store your sessions in a database
+
+BUILD_DEPENDS= p5-Catalyst>=5.49:${PORTSDIR}/www/p5-Catalyst \
+ p5-Catalyst-Plugin-Session>=0.05:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Session::Store::DBI.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500801
+IGNORE= requires Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-Store-DBI/distinfo b/www/p5-Catalyst-Plugin-Session-Store-DBI/distinfo
new file mode 100644
index 000000000000..c8b9e8642b29
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-DBI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-Store-DBI-0.05.tar.gz) = cc0037de7aac907a8739b8490493e77e
+SHA256 (Catalyst-Plugin-Session-Store-DBI-0.05.tar.gz) = a669a3e080bced7ea003d70cfac60401e633e09741c8243ce5bc7d1cc1b1b796
+SIZE (Catalyst-Plugin-Session-Store-DBI-0.05.tar.gz) = 6528
diff --git a/www/p5-Catalyst-Plugin-Session-Store-DBI/pkg-descr b/www/p5-Catalyst-Plugin-Session-Store-DBI/pkg-descr
new file mode 100644
index 000000000000..e2de5534a625
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-DBI/pkg-descr
@@ -0,0 +1,3 @@
+This storage module will store session data in a database using DBI.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-DBI/
diff --git a/www/p5-Catalyst-Plugin-Session-Store-DBI/pkg-plist b/www/p5-Catalyst-Plugin-Session-Store-DBI/pkg-plist
new file mode 100644
index 000000000000..40b382f40163
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-DBI/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store/DBI.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true