aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CatalystX-InjectComponent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-CatalystX-InjectComponent/Makefile')
-rw-r--r--www/p5-CatalystX-InjectComponent/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-CatalystX-InjectComponent/Makefile b/www/p5-CatalystX-InjectComponent/Makefile
new file mode 100644
index 000000000000..27c1ddcc8adb
--- /dev/null
+++ b/www/p5-CatalystX-InjectComponent/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-CatalystX-InjectComponent
+# Date created: 2011-05-08
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CatalystX-InjectComponent
+PORTVERSION= 0.024
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RKRIMEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Inject components into your Catalyst application
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.8:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS= p5-Catalyst-Runtime>=5.8:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= CatalystX::InjectComponent.3
+
+.include <bsd.port.mk>