aboutsummaryrefslogtreecommitdiff
path: root/www/p5-FEAR-API/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-FEAR-API/Makefile')
-rw-r--r--www/p5-FEAR-API/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/www/p5-FEAR-API/Makefile b/www/p5-FEAR-API/Makefile
new file mode 100644
index 000000000000..eb8a942c47a5
--- /dev/null
+++ b/www/p5-FEAR-API/Makefile
@@ -0,0 +1,57 @@
+# ex:ts=8
+# Ports collection makefile for: FEAR::API
+# Date created: Jun 5, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= FEAR-API
+PORTVERSION= 0.487.3
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/X/XE/XERN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Web Scraping Zen
+
+BUILD_DEPENDS= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Email-Find>=0:${PORTSDIR}/mail/p5-Email-Find \
+ p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-File-Temp>=0:${PORTSDIR}/devel/p5-File-Temp \
+ p5-HTML-Encoding>=0:${PORTSDIR}/www/p5-HTML-Encoding \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTML-LinkExtractor>=0:${PORTSDIR}/www/p5-HTML-LinkExtractor \
+ p5-HTTP-Proxy>=0:${PORTSDIR}/www/p5-HTTP-Proxy \
+ p5-HTTP-Recorder>=0:${PORTSDIR}/www/p5-HTTP-Recorder \
+ p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
+ p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
+ p5-Inline>=0:${PORTSDIR}/devel/p5-Inline \
+ p5-Inline-Files>=0:${PORTSDIR}/devel/p5-Inline-Files \
+ p5-Net-Server>=0:${PORTSDIR}/net/p5-Net-Server \
+ p5-Parallel-ForkManager>=0:${PORTSDIR}/devel/p5-Parallel-ForkManager \
+ p5-Regexp-Bind>=0:${PORTSDIR}/devel/p5-Regexp-Bind \
+ p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Sort-Versions>=0:${PORTSDIR}/devel/p5-Sort-Versions \
+ p5-Spiffy>=0:${PORTSDIR}/devel/p5-Spiffy \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-Template-Extract>=0:${PORTSDIR}/textproc/p5-Template-Extract \
+ p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
+ p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv \
+ p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-XML-RSS-SimpleGen>=0:${PORTSDIR}/textproc/p5-XML-RSS-SimpleGen \
+ p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= fear.1
+MAN3= FEAR::API.3 \
+ FEAR::API::Filters.3 \
+ FEAR::API::Document.3
+
+.include <bsd.port.mk>