aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Request-Params/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-HTTP-Request-Params/Makefile')
-rw-r--r--www/p5-HTTP-Request-Params/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-HTTP-Request-Params/Makefile b/www/p5-HTTP-Request-Params/Makefile
new file mode 100644
index 000000000000..20f053cfd2d3
--- /dev/null
+++ b/www/p5-HTTP-Request-Params/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-HTTP-Request-Params
+# Date created: 22 Nov 2005
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Request-Params
+PORTVERSION= 1.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Retrieve GET/POST Parameters from HTTP Requests
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Email/MIME/Modifier.pm:${PORTSDIR}/mail/p5-Email-MIME-Modifier \
+ ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Request::Params.3
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.mk>