aboutsummaryrefslogtreecommitdiff
path: root/www/p5-LWP-Authen-OAuth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-LWP-Authen-OAuth/Makefile')
-rw-r--r--www/p5-LWP-Authen-OAuth/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-LWP-Authen-OAuth/Makefile b/www/p5-LWP-Authen-OAuth/Makefile
new file mode 100644
index 000000000000..dfb2f6847192
--- /dev/null
+++ b/www/p5-LWP-Authen-OAuth/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: LWP::Authen::OAuth
+# Date created: 18 May 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-Authen-OAuth
+PORTVERSION= 1.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to generate signed OAuth requests
+
+RUN_DEPENDS= \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Authen::OAuth.3
+
+.include <bsd.port.mk>