aboutsummaryrefslogtreecommitdiff
path: root/www/p5-POE-Component-Client-HTTP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-POE-Component-Client-HTTP/Makefile')
-rw-r--r--www/p5-POE-Component-Client-HTTP/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/p5-POE-Component-Client-HTTP/Makefile b/www/p5-POE-Component-Client-HTTP/Makefile
index 1b38f2558b66..4c77c1509e50 100644
--- a/www/p5-POE-Component-Client-HTTP/Makefile
+++ b/www/p5-POE-Component-Client-HTTP/Makefile
@@ -6,22 +6,24 @@
#
PORTNAME= POE-Component-Client-HTTP
-PORTVERSION= 0.41
+PORTVERSION= 0.43
CATEGORIES= devel perl5 www
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
http://poe.perl.org/poedown/
MASTER_SITE_SUBDIR= POE
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@protey.ru
+MAINTAINER= skv@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/SSLeay/Handle.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= POE::Component::Client::HTTP.3
+MAN3= POE::Component::Client::HTTP.3 POE::Component::Client::SSL.3
.include <bsd.port.mk>