aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Plack-App-Proxy
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Plack-App-Proxy')
-rw-r--r--www/p5-Plack-App-Proxy/Makefile32
-rw-r--r--www/p5-Plack-App-Proxy/distinfo3
-rw-r--r--www/p5-Plack-App-Proxy/pkg-descr3
-rw-r--r--www/p5-Plack-App-Proxy/pkg-plist11
4 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-Plack-App-Proxy/Makefile b/www/p5-Plack-App-Proxy/Makefile
new file mode 100644
index 000000000000..cd6ff954c62b
--- /dev/null
+++ b/www/p5-Plack-App-Proxy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Plack::App::Proxy
+# Date created: 04 Apr 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-App-Proxy
+PORTVERSION= 0.15
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Plack extension for proxy requests
+
+RUN_DEPENDS= \
+ p5-AnyEvent-HTTP>=1.44:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Plack>=0.9913:${PORTSDIR}/www/p5-Plack
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::App::Proxy.3 \
+ Plack::App::Proxy::Test.3 \
+ Plack::Middleware::Proxy::AddVia.3 \
+ Plack::Middleware::Proxy::Connect.3 \
+ Plack::Middleware::Proxy::LoadBalancer.3 \
+ Plack::Middleware::Proxy::RewriteLocation.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Plack-App-Proxy/distinfo b/www/p5-Plack-App-Proxy/distinfo
new file mode 100644
index 000000000000..875b1871940f
--- /dev/null
+++ b/www/p5-Plack-App-Proxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Plack-App-Proxy-0.15.tar.gz) = 5158ec8c4adfcceaee86c93a92dc3638
+SHA256 (Plack-App-Proxy-0.15.tar.gz) = 99352eeef9c62e4a54b915a85f0ae7de442f432d0d23ddb8b00266adfa97016c
+SIZE (Plack-App-Proxy-0.15.tar.gz) = 27061
diff --git a/www/p5-Plack-App-Proxy/pkg-descr b/www/p5-Plack-App-Proxy/pkg-descr
new file mode 100644
index 000000000000..95a51595702d
--- /dev/null
+++ b/www/p5-Plack-App-Proxy/pkg-descr
@@ -0,0 +1,3 @@
+Plack::App::Proxy is a middleware-aware proxy application for Plack.
+
+WWW: http://search.cpan.org/dist/Plack-App-Proxy/
diff --git a/www/p5-Plack-App-Proxy/pkg-plist b/www/p5-Plack-App-Proxy/pkg-plist
new file mode 100644
index 000000000000..4a0b4a3d5c93
--- /dev/null
+++ b/www/p5-Plack-App-Proxy/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/App/Proxy/.packlist
+%%SITE_PERL%%/Plack/App/Proxy.pm
+%%SITE_PERL%%/Plack/App/Proxy/Test.pm
+%%SITE_PERL%%/Plack/Middleware/Proxy/AddVia.pm
+%%SITE_PERL%%/Plack/Middleware/Proxy/Connect.pm
+%%SITE_PERL%%/Plack/Middleware/Proxy/LoadBalancer.pm
+%%SITE_PERL%%/Plack/Middleware/Proxy/RewriteLocation.pm
+@dirrmtry %%SITE_PERL%%/Plack/Middleware/Proxy
+@dirrm %%SITE_PERL%%/Plack/App/Proxy
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/App/Proxy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/App