aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Plack-Middleware-ServerStatus-Lite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Plack-Middleware-ServerStatus-Lite/Makefile')
-rw-r--r--www/p5-Plack-Middleware-ServerStatus-Lite/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/p5-Plack-Middleware-ServerStatus-Lite/Makefile b/www/p5-Plack-Middleware-ServerStatus-Lite/Makefile
new file mode 100644
index 000000000000..e2af78bdc68c
--- /dev/null
+++ b/www/p5-Plack-Middleware-ServerStatus-Lite/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Plack::Middleware::ServerStatus::Lite
+# Date created: 29 Jan 2012
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-Middleware-ServerStatus-Lite
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Plack middleware to show server status like Apache mod_status
+
+RUN_DEPENDS= \
+ p5-Net-CIDR-Lite>0:${PORTSDIR}/net/p5-Net-CIDR-Lite \
+ p5-Parallel-Scoreboard>=0.02:${PORTSDIR}/devel/p5-Parallel-Scoreboard \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-Try-Tiny>=0.09:${PORTSDIR}/lang/p5-Try-Tiny
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::Middleware::ServerStatus::Lite.3
+
+.include <bsd.port.mk>