aboutsummaryrefslogtreecommitdiff
path: root/www/p5-SCGI
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-SCGI')
-rw-r--r--www/p5-SCGI/Makefile31
-rw-r--r--www/p5-SCGI/distinfo3
-rw-r--r--www/p5-SCGI/pkg-descr4
3 files changed, 38 insertions, 0 deletions
diff --git a/www/p5-SCGI/Makefile b/www/p5-SCGI/Makefile
new file mode 100644
index 000000000000..7f61f034e5ab
--- /dev/null
+++ b/www/p5-SCGI/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-SCGI
+# Date created: Fri Jan 5 13:55:53 EST 2007
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SCGI
+PORTVERSION= 0.6
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/V/VI/VIPERCODE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= SCGI server interface
+
+PERL_MODBUILD= yes
+
+MAN3= SCGI.3 SCGI::Request.3
+
+PLIST_FILES= ${SITE_PERL_REL}/SCGI.pm ${SITE_PERL_REL}/SCGI/Request.pm
+PLIST_DIRS= ${SITE_PERL_REL}/SCGI
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-SCGI/distinfo b/www/p5-SCGI/distinfo
new file mode 100644
index 000000000000..843f45fb3885
--- /dev/null
+++ b/www/p5-SCGI/distinfo
@@ -0,0 +1,3 @@
+MD5 (SCGI-0.6.tar.gz) = 88d5fdde94da8cc7f63844ef4a0df4d5
+SHA256 (SCGI-0.6.tar.gz) = 58b78c5af4ee45e437f07ae8f3b0d945c91fd2c025156ee916d811580f91d9a4
+SIZE (SCGI-0.6.tar.gz) = 6192
diff --git a/www/p5-SCGI/pkg-descr b/www/p5-SCGI/pkg-descr
new file mode 100644
index 000000000000..d039001c5b5f
--- /dev/null
+++ b/www/p5-SCGI/pkg-descr
@@ -0,0 +1,4 @@
+This Perl module is for implementing the SCGI interface for an application
+server. Essentially, it is a 'next generation' FastCGI type protocol.
+
+WWW: http://python.ca/nas/scgi/protocol.txt