aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Template-Toolkit-Simple
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Template-Toolkit-Simple')
-rw-r--r--www/p5-Template-Toolkit-Simple/Makefile24
-rw-r--r--www/p5-Template-Toolkit-Simple/distinfo3
-rw-r--r--www/p5-Template-Toolkit-Simple/pkg-descr15
-rw-r--r--www/p5-Template-Toolkit-Simple/pkg-plist8
4 files changed, 50 insertions, 0 deletions
diff --git a/www/p5-Template-Toolkit-Simple/Makefile b/www/p5-Template-Toolkit-Simple/Makefile
new file mode 100644
index 000000000000..0d80e684d25d
--- /dev/null
+++ b/www/p5-Template-Toolkit-Simple/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Template-Toolkit-Simple
+# Date created: 2010-04-24
+# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Toolkit-Simple
+PORTVERSION= 0.03
+CATEGORIES= www textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= A Simple Interface to Template Toolkit
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Toolkit::Simple.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Template-Toolkit-Simple/distinfo b/www/p5-Template-Toolkit-Simple/distinfo
new file mode 100644
index 000000000000..5cbca97fbba9
--- /dev/null
+++ b/www/p5-Template-Toolkit-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Toolkit-Simple-0.03.tar.gz) = c897a574b33c8935cf5dbfa96a974acf
+SHA256 (Template-Toolkit-Simple-0.03.tar.gz) = 706939312f60dc8c13a6ba8c58818ecbf40176dd9760b1ca8f02e565485c9fa4
+SIZE (Template-Toolkit-Simple-0.03.tar.gz) = 17260
diff --git a/www/p5-Template-Toolkit-Simple/pkg-descr b/www/p5-Template-Toolkit-Simple/pkg-descr
new file mode 100644
index 000000000000..cd4e217735f8
--- /dev/null
+++ b/www/p5-Template-Toolkit-Simple/pkg-descr
@@ -0,0 +1,15 @@
+Template Toolkit is the best Perl template framework. The only problem
+with it is that using it for simple stuff is a little bit cumbersome.
+Also there is no good utility for using it from the command line.
+
+This module is a simple wrapper around Template Toolkit. It exports a
+function called tt which returns a new Template::Toolkit::Simple object.
+The object supports method calls for setting all the Template Toolkit
+options.
+
+This module also installs a program called tt-render which you can use
+from the command line to render templates with all the power of the Perl
+object. All of the object methods become command line arguments in the
+command line version.
+
+WWW: http://search.cpan.org/dist/Template-Toolkit-Simple/
diff --git a/www/p5-Template-Toolkit-Simple/pkg-plist b/www/p5-Template-Toolkit-Simple/pkg-plist
new file mode 100644
index 000000000000..472852241ded
--- /dev/null
+++ b/www/p5-Template-Toolkit-Simple/pkg-plist
@@ -0,0 +1,8 @@
+bin/tt-render
+%%SITE_PERL%%/Template/Toolkit/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Toolkit/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Toolkit/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Toolkit
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template
+@dirrmtry %%SITE_PERL%%/Template/Toolkit
+@dirrmtry %%SITE_PERL%%/Template