aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Google-Video/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-WWW-Google-Video/Makefile')
-rw-r--r--www/p5-WWW-Google-Video/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/p5-WWW-Google-Video/Makefile b/www/p5-WWW-Google-Video/Makefile
new file mode 100644
index 000000000000..076e479506f4
--- /dev/null
+++ b/www/p5-WWW-Google-Video/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WWW-Google-Video
+# Date created: 2006-07-19
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Google-Video
+PORTVERSION= 0.3
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW/KENWU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= This's a interface for fetch the Google Video Information
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Google::Video.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>