aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Mechanize/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-WWW-Mechanize/Makefile')
-rw-r--r--www/p5-WWW-Mechanize/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/p5-WWW-Mechanize/Makefile b/www/p5-WWW-Mechanize/Makefile
index 90be75bd4322..fd1aebf50fbf 100644
--- a/www/p5-WWW-Mechanize/Makefile
+++ b/www/p5-WWW-Mechanize/Makefile
@@ -17,7 +17,6 @@ COMMENT= This module is to help you automate interaction with a website
BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -31,6 +30,8 @@ MAN1= mech-dump.1
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
@@ -41,5 +42,6 @@ post-patch:
-e '$$_="" if /use warnings/;' \
${WRKSRC}/lib/WWW/Mechanize.pm ${WRKSRC}/lib/WWW/Mechanize/Link.pm
.endif
+.endif
.include <bsd.port.post.mk>