aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WebService-Basecamp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-WebService-Basecamp/Makefile')
-rw-r--r--www/p5-WebService-Basecamp/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/p5-WebService-Basecamp/Makefile b/www/p5-WebService-Basecamp/Makefile
new file mode 100644
index 000000000000..cc3d0f7e18c2
--- /dev/null
+++ b/www/p5-WebService-Basecamp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WebService-Basecamp
+# Date created: 2006-08-18
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-Basecamp
+PORTVERSION= 0.1.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WebService
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl interface to the Basecamp API webservice
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::Basecamp.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>