aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WebService-NoPaste
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-WebService-NoPaste')
-rw-r--r--www/p5-WebService-NoPaste/Makefile29
-rw-r--r--www/p5-WebService-NoPaste/pkg-descr3
-rw-r--r--www/p5-WebService-NoPaste/pkg-plist4
3 files changed, 16 insertions, 20 deletions
diff --git a/www/p5-WebService-NoPaste/Makefile b/www/p5-WebService-NoPaste/Makefile
index 69b8e90efbf4..e0aacef8109b 100644
--- a/www/p5-WebService-NoPaste/Makefile
+++ b/www/p5-WebService-NoPaste/Makefile
@@ -8,31 +8,28 @@ MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= A pastebin web application to upload snippets of text
+COMMENT= Pastebin web application to upload snippets of text
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
BUILD_DEPENDS= p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-Spiffy>=0:${PORTSDIR}/devel/p5-Spiffy
+ p5-Spiffy>=0:${PORTSDIR}/devel/p5-Spiffy \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= shebangfix perl5
-USE_PERL5= configure
-SHEBANG_FILES= nopaste
-
OPTIONS_DEFINE= X11
X11_DESC= X11 Clipboard support
-.include <bsd.port.options.mk>
+USE_PERL5= configure
+USES= shebangfix perl5
+
+SHEBANG_FILES= nopaste
-.if ${PORT_OPTIONS:MX11}
-BUILD_DEPENDS+= p5-Clipboard>=0:${PORTSDIR}/x11/p5-Clipboard
-.else
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-lib-WebService-NoPaste.pm
-.endif
+X11_BUILD_DEPENDS= p5-Clipboard>=0:${PORTSDIR}/x11/p5-Clipboard
+X11_EXTRA_PATCHES_OFF= ${FILESDIR}/extrapatch-lib-WebService-NoPaste.pm
post-patch:
-.if ! ${PORT_OPTIONS:MX11}
- @${RM} ${WRKSRC}/lib/WebService/NoPaste.pm.orig
-.endif
+ -@${RM} ${WRKSRC}/lib/WebService/NoPaste.pm.orig
.include <bsd.port.mk>
diff --git a/www/p5-WebService-NoPaste/pkg-descr b/www/p5-WebService-NoPaste/pkg-descr
index d3d8f350961a..0fc433dfecb2 100644
--- a/www/p5-WebService-NoPaste/pkg-descr
+++ b/www/p5-WebService-NoPaste/pkg-descr
@@ -1,5 +1,4 @@
A pastebin web application to upload snippets of text to a webserver. Pastebins
are often used in IRC channels to show large amuonts of text.
-Author: Ryan King <rking@panoptic.com>
-WWW: http://search.cpan.org/dist/WebService-NoPaste/
+WWW: http://search.cpan.org/dist/WebService-NoPaste/
diff --git a/www/p5-WebService-NoPaste/pkg-plist b/www/p5-WebService-NoPaste/pkg-plist
index 1f18e2d64ca5..ad84ebad6fbf 100644
--- a/www/p5-WebService-NoPaste/pkg-plist
+++ b/www/p5-WebService-NoPaste/pkg-plist
@@ -1,7 +1,7 @@
bin/nopaste
-%%PERL5_MAN3%%/WebService::NoPaste.3.gz
%%SITE_PERL%%/WebService/NoPaste.pm
-@dirrmtry %%SITE_PERL%%/WebService
%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/NoPaste/.packlist
+%%PERL5_MAN3%%/WebService::NoPaste.3.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/NoPaste
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService
+@dirrmtry %%SITE_PERL%%/WebService