aboutsummaryrefslogtreecommitdiff
path: root/www/p5-libapreq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-libapreq/Makefile')
-rw-r--r--www/p5-libapreq/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/www/p5-libapreq/Makefile b/www/p5-libapreq/Makefile
index b48b71f98ce2..5314ec2e01a5 100644
--- a/www/p5-libapreq/Makefile
+++ b/www/p5-libapreq/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libapreq
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= www perl5 devel
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/J/JI/JIMW/
@@ -15,16 +15,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Generic Apache Request Library
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Apache/src.pm:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache/src.pm:${PORTSDIR}/www/mod_perl
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::Cookie.3 Apache::Request.3 Apache::libapreq.3 \
libapreq.3
+post-patch:
+ @${PERL} -pi~ -e '$$_="" if $$. >8 && $$. <27' ${WRKSRC}/Makefile.PL
+
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"