aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Services_ShortURL
diff options
context:
space:
mode:
Diffstat (limited to 'www/pear-Services_ShortURL')
-rw-r--r--www/pear-Services_ShortURL/Makefile45
-rw-r--r--www/pear-Services_ShortURL/distinfo2
-rw-r--r--www/pear-Services_ShortURL/pkg-descr6
3 files changed, 53 insertions, 0 deletions
diff --git a/www/pear-Services_ShortURL/Makefile b/www/pear-Services_ShortURL/Makefile
new file mode 100644
index 000000000000..f971cd4c8f9f
--- /dev/null
+++ b/www/pear-Services_ShortURL/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: pear-Services_ShortURL
+# Date created: 06 April 2011
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_ShortURL
+PORTVERSION= 0.3.1
+CATEGORIES= www pear
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Abstract PHP5 interface for shortening and expanding short URLs
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+
+USE_PHP= simplexml pcre spl
+
+CATEGORY= Services
+PEAR_CATSRC= yes
+
+FILES= ShortURL/Bitly.php \
+ ShortURL/Common.php \
+ ShortURL/Digg.php \
+ ShortURL/Exception/CouldNotExpand.php \
+ ShortURL/Exception/CouldNotShorten.php \
+ ShortURL/Exception/InvalidOptions.php \
+ ShortURL/Exception/NotImplemented.php \
+ ShortURL/Exception/UnknownService.php \
+ ShortURL/Exception.php \
+ ShortURL/Googl.php \
+ ShortURL/Interface.php \
+ ShortURL/Isgd.php \
+ ShortURL/Shortie.php \
+ ShortURL/TinyURL.php \
+ ShortURL/Trim.php \
+ ShortURL.php
+
+TESTS= AllTests.php Services/ShortURLTest.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_ShortURL/distinfo b/www/pear-Services_ShortURL/distinfo
new file mode 100644
index 000000000000..844a5fd25966
--- /dev/null
+++ b/www/pear-Services_ShortURL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/Services_ShortURL-0.3.1.tgz) = 85fa6affdf9fc0ea3e997576874d71737a3236190891ecf0f7046909181fb0db
+SIZE (PEAR/Services_ShortURL-0.3.1.tgz) = 9539
diff --git a/www/pear-Services_ShortURL/pkg-descr b/www/pear-Services_ShortURL/pkg-descr
new file mode 100644
index 000000000000..a664513d4b9f
--- /dev/null
+++ b/www/pear-Services_ShortURL/pkg-descr
@@ -0,0 +1,6 @@
+Short URL services have become enormously popular on the internet.
+There are, literally, dozens (hundreds?) of these services.
+Services_ShortURL offers an abstract way of shortening and expanding
+URLs.
+
+WWW: http://pear.php.net/package/Services_ShortURL/