aboutsummaryrefslogtreecommitdiff
path: root/www/pecl-APC
diff options
context:
space:
mode:
Diffstat (limited to 'www/pecl-APC')
-rw-r--r--www/pecl-APC/Makefile3
-rw-r--r--www/pecl-APC/distinfo6
-rw-r--r--www/pecl-APC/files/patch-apc_main.c30
3 files changed, 4 insertions, 35 deletions
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index 5c54df540f9a..ef81fa0c4479 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= APC
-DISTVERSION= 3.0.18
-PORTREVISION= 1
+DISTVERSION= 3.0.19
CATEGORIES= www
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/www/pecl-APC/distinfo b/www/pecl-APC/distinfo
index f7c68d099593..97e3ea6f5793 100644
--- a/www/pecl-APC/distinfo
+++ b/www/pecl-APC/distinfo
@@ -1,3 +1,3 @@
-MD5 (PECL/APC-3.0.18.tgz) = 491d63dfa35f9b6ff7421059aa448d4a
-SHA256 (PECL/APC-3.0.18.tgz) = e3e191909e696bc826cb70d86d24ac5e83a71c843f20e53034cf4f52ba9228b0
-SIZE (PECL/APC-3.0.18.tgz) = 115957
+MD5 (PECL/APC-3.0.19.tgz) = 951f43d2873e3572f5d5ae71a9b66f90
+SHA256 (PECL/APC-3.0.19.tgz) = a02677a7884361d64fbf3745c402f2a6ff313e817b0d0a2010acb64cd05247b0
+SIZE (PECL/APC-3.0.19.tgz) = 115735
diff --git a/www/pecl-APC/files/patch-apc_main.c b/www/pecl-APC/files/patch-apc_main.c
deleted file mode 100644
index 1c468911909b..000000000000
--- a/www/pecl-APC/files/patch-apc_main.c
+++ /dev/null
@@ -1,30 +0,0 @@
-#
-# Fix FD leak to PHP4 (from pecl-APC CVS)
-#
---- apc_main.c 2008/03/29 06:38:40 3.103.2.3
-+++ apc_main.c 2008/03/31 14:14:12 3.103.2.4
-@@ -279,7 +279,11 @@
- apc_cache_release(apc_cache, cache_entry);
-
- /* cannot free up cache data yet, it maybe in use */
--
-+
-+#ifndef ZEND_ENGINE_2
-+ zend_llist_del_element(&CG(open_files), h, compare_file_handles); /* We leak fds in PHP 4 without this hack */
-+#endif
-+
- h->type = ZEND_HANDLE_FILENAME;
-
- return NULL;
-@@ -351,6 +355,11 @@
- reset_opened_path = 1;
- }
- zend_hash_add(&EG(included_files), h->opened_path, strlen(h->opened_path)+1, (void *)&dummy, sizeof(int), NULL);
-+
-+#ifndef ZEND_ENGINE_2
-+ zend_llist_add_element(&CG(open_files), h); /* We leak fds in PHP 4 without this hack */
-+#endif
-+
- apc_stack_push(APCG(cache_stack), cache_entry);
- op_array = cached_compile(h, type TSRMLS_CC);
- if(op_array) {