aboutsummaryrefslogtreecommitdiff
path: root/www/pivotx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/pivotx/Makefile')
-rw-r--r--www/pivotx/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/www/pivotx/Makefile b/www/pivotx/Makefile
index 8fc0783b7e10..8ad476d75f18 100644
--- a/www/pivotx/Makefile
+++ b/www/pivotx/Makefile
@@ -6,30 +6,33 @@
#
PORTNAME= pivotx
-PORTVERSION= 2.2.6
+PORTVERSION= 2.3.0
CATEGORIES= www
-MASTER_SITES= SF/pivot-weblog/PivotX http://pivotx.net/files/ http://pivotx.net/files/archived/
-DISTNAME= pivotx_226
+MASTER_SITES= SF/pivot-weblog/PivotX \
+ http://pivotx.net/files/ \
+ http://pivotx.net/files/archived/
+DISTNAME= pivotx_2.3.0
EXTRACT_SUFX= .tgz
MAINTAINER= fumifumi@abacustech.jp
COMMENT= Software to help you maintain dynamic sites such as weblogs
-DOCS= LICENSE.txt README.txt example.htaccess
-DOCS_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-${PORTREVISION}-docs
-
LICENSE= GPLv2
LICENSE_FILE= ${DOCS_WRKSRC}/LICENSE.txt
+DOCS= LICENSE.txt README.txt example.htaccess
+DOCS_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-${PORTREVISION}-docs
+
# Requirements:
# http://book.pivotx.net/index.php?page=app-e#anchor-determining-if-your-server-meets-pivotxs-requirements
OPTIONS= MYSQL "Use MySQL instead of flat files" off
+
.include <bsd.port.options.mk>
WANT_PHP_WEB= yes
IGNORE_WITH_PHP=4
-USE_PHP= session gettext xml gd pcre
+USE_PHP= session gettext xml gd pcre tokenizer
USE_GETTEXT= yes
.if exists(${PHPBASE}/lib/php/${PHP_EXT_DIR}/simplexml.so) || !exists(${PHPBASE}/lib/php/${PHP_EXT_DIR}/dom.so)