aboutsummaryrefslogtreecommitdiff
path: root/www/pound/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/pound/Makefile')
-rw-r--r--www/pound/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/pound/Makefile b/www/pound/Makefile
index 1d655dab1a3a..3e75600990c1 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pound
-PORTVERSION= 2.3.2
-PORTREVISION= 1
+PORTVERSION= 2.4
CATEGORIES= www net
MASTER_SITES= http://www.apsis.ch/pound/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -37,6 +36,8 @@ OPTIONS= DAEMON "Running as a daemon" on \
.include <bsd.port.pre.mk>
+PORTDOCS= README FAQ CHANGELOG
+
.if defined(WITHOUT_DAEMON)
CONFIGURE_ARGS+= --disable-daemon
.endif
@@ -68,8 +69,9 @@ CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/FAQ ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.post.mk>