aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-simple-captcha/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-django-simple-captcha/Makefile')
-rw-r--r--www/py-django-simple-captcha/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/www/py-django-simple-captcha/Makefile b/www/py-django-simple-captcha/Makefile
index 1a86e9120212..6852e223e7ea 100644
--- a/www/py-django-simple-captcha/Makefile
+++ b/www/py-django-simple-captcha/Makefile
@@ -16,7 +16,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=1.7.0:www/py-django111@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}django-ranged-response>=0.2.0:www/py-django-ranged-response@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>=1.2.0:devel/py-six@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}six>=1.2.0:devel/py-six@${PY_FLAVOR} \
+ ${PY_PILLOW}
USES= python zip
USE_PYTHON= autoplist concurrent distutils
@@ -31,16 +32,8 @@ DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
MIGRATIONS_DESC= Schema and data migration support (via south)
MIGRATIONS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}south>0:databases/py-south@${PY_FLAVOR}
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3500
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=2.2.2:graphics/py-pillow6@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.2:graphics/py-pillow@${PY_FLAVOR}
-.endif
-
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/build/sphinx/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -name objects.inv")
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>