aboutsummaryrefslogtreecommitdiff
path: root/www/py-django15/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-django15/Makefile')
-rw-r--r--www/py-django15/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/www/py-django15/Makefile b/www/py-django15/Makefile
index 79e58f1c52fc..3c6213695caf 100644
--- a/www/py-django15/Makefile
+++ b/www/py-django15/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= django
-PORTVERSION= 1.5.8
+PORTVERSION= 1.5.9
CATEGORIES= www python
MASTER_SITES= https://www.djangoproject.com/m/releases/${PORTVERSION:R}/ \
CHEESESHOP
@@ -15,22 +15,23 @@ MAINTAINER= lwhsu@FreeBSD.org
COMMENT= High-level Python Web framework
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= cpe
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
CONFLICTS= py[23][0-9]-django-devel-[0-9]* py[23][0-9]-django-1.[0-46-9].*
+CPE_VENDOR= djangoproject
DOCSDIR= ${PREFIX}/share/doc/py-django
-# bypass infrastructure bug
-OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
OPTIONS_DEFINE= FASTCGI HTMLDOCS
OPTIONS_DEFAULT=SQLITE
OPTIONS_GROUP= DATABASE
OPTIONS_GROUP_DATABASE= PGSQL MYSQL SQLITE
-HTMLDOCS_DESC= Install the HTML documentation (requires Sphinx)
+HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
PLIST_FILES= man/man1/daily_cleanup.1.gz \
man/man1/django-admin.1.gz \