aboutsummaryrefslogtreecommitdiff
path: root/www/py-graphite-web/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-graphite-web/Makefile')
-rw-r--r--www/py-graphite-web/Makefile39
1 files changed, 29 insertions, 10 deletions
diff --git a/www/py-graphite-web/Makefile b/www/py-graphite-web/Makefile
index 317ecd091ecd..0b656059ad30 100644
--- a/www/py-graphite-web/Makefile
+++ b/www/py-graphite-web/Makefile
@@ -3,32 +3,51 @@
PORTNAME= graphite-web
PORTVERSION= 0.9.12
+PORTREVISION= 1
CATEGORIES= www python
-MASTER_SITES= https://github.com/graphite-project/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=
+MASTER_SITES= http://github.com/graphite-project/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= bsdports@wayfair.com
+MAINTAINER= swills@FreeBSD.org
COMMENT= Enterprise scalable realtime graphing platform
+LICENSE= APACHE20
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.10:${PORTSDIR}/graphics/py-cairo \
${PYTHON_PKGNAMEPREFIX}carbon>=${PORTVERSION}:${PORTSDIR}/databases/py-carbon \
${PYTHON_PKGNAMEPREFIX}django>=1.4:${PORTSDIR}/www/py-django \
- ${PYTHON_PKGNAMEPREFIX}django-tagging>=0.3.1:${PORTSDIR}/www/py-django-tagging
+ ${PYTHON_PKGNAMEPREFIX}django-tagging>=0.3.1:${PORTSDIR}/www/py-django-tagging \
+ xorg-fonts-truetype>=0:${PORTSDIR}/x11-fonts/xorg-fonts-truetype
FETCH_ARGS= -o ${DISTNAME}${EXTRACT_SUFX}
USE_PYTHON= 2
USE_PYDISTUTILS=yes
+SUB_FILES= pkg-message
+SUB_LIST+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} WWWOWN=${WWWOWN} \
+ WWWGRP=${WWWGRP} DATADIR=${DATADIR}
+PLIST_SUB+= RESETPREFIX=${PREFIX}
-NO_STAGE= yes
post-patch:
- @${MKDIR} ${WRKSRC}/graphite/webapp/
- @${CP} -LR ${WRKSRC}/webapp/content ${WRKSRC}/graphite/webapp
@${RM} ${WRKSRC}/bin/build-index.sh.orig
+ @${RM} ${WRKSRC}/bin/run-graphite-devel-server.py
+ @${REINPLACE_CMD} -i '' -e 's|%%PREFIX%%|${PREFIX}|' \
+ -e 's|%%DATADIR%%|${DATADIR}|' \
+ ${WRKSRC}/bin/build-index.sh \
+ ${WRKSRC}/conf/graphite.wsgi.example \
+ ${WRKSRC}/setup.cfg \
+ ${WRKSRC}/setup.py \
+ ${WRKSRC}/webapp/graphite/local_settings.py.example
post-install:
- @${ECHO} ${PYTHON_SITELIBDIR}
- ${CHOWN} ${WWWOWN} ${PREFIX}/graphite/storage
- ${CHOWN} ${WWWOWN} ${PREFIX}/graphite/storage/log/webapp
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/examples
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/examples)
+ @${MKDIR} ${STAGEDIR}${DATADIR}/content
+ @(cd ${WRKSRC}/webapp/content && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/content)
+ @${MKDIR} -p ${STAGEDIR}/var/log/graphite/webapp
+ @${MKDIR} -p ${STAGEDIR}/var/db/graphite
+ @${CHOWN} ${WWWOWN} ${STAGEDIR}/var/log/graphite
+ @${CHOWN} ${WWWOWN} ${STAGEDIR}/var/db/graphite
+ @${CP} ${STAGEDIR}${PYTHON_SITELIBDIR}/graphite/local_settings.py.example ${STAGEDIR}${PREFIX}/etc/graphite/local_settings.py.example
+ @${LN} -s ${PREFIX}/etc/graphite/local_settings.py ${STAGEDIR}${PYTHON_SITELIBDIR}/graphite/local_settings.py
.include <bsd.port.mk>