aboutsummaryrefslogtreecommitdiff
path: root/www/py-httmock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-httmock/Makefile')
-rw-r--r--www/py-httmock/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/www/py-httmock/Makefile b/www/py-httmock/Makefile
index 257109e160ac..f550e348fafa 100644
--- a/www/py-httmock/Makefile
+++ b/www/py-httmock/Makefile
@@ -3,13 +3,7 @@
PORTNAME= httmock
PORTVERSION= 1.3.0
CATEGORIES= www python
-MASTER_SITES= CHEESESHOP \
- https://raw.githubusercontent.com/patrys/${PORTNAME}/${PORTVERSION}/:tests
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- tests.py:tests
-DIST_SUBDIR= py-${PORTNAME}
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dereks@lifeofadishwasher.com
COMMENT= Mocking library for requests
@@ -20,15 +14,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=1.0.0:www/py-requests@${PY_FLAVOR}
USES= python
+USE_GITHUB= yes # tests missing from PyPI sdist
USE_PYTHON= distutils autoplist
-NO_ARCH= yes
+GH_ACCOUNT= patrys
-# Description: tests.py is missing from the pypi package
-# Issue ID: https://github.com/patrys/httmock/issues/55
-# TODO: Remove extra MASTER_SITES, DISTFILES/SUBDIR, EXTRACT_ONLY, post-extract
-post-extract:
- @${CP} ${DISTDIR}/${DIST_SUBDIR}/tests.py ${WRKSRC}
+NO_ARCH= yes
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test