aboutsummaryrefslogtreecommitdiff
path: root/www/py-plone.app.registry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-plone.app.registry/Makefile')
-rw-r--r--www/py-plone.app.registry/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/py-plone.app.registry/Makefile b/www/py-plone.app.registry/Makefile
new file mode 100644
index 000000000000..cc28706e18d5
--- /dev/null
+++ b/www/py-plone.app.registry/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: py-plone.app.registry
+# Date created: 03 January 2012
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone.app.registry
+PORTVERSION= 1.0.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Zope 2 and Plone integration for plone.registry
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.registry>=1.0:${PORTSDIR}/www/py-plone.registry \
+ ${PYTHON_PKGNAMEPREFIX}plone.supermodel>=1.0:${PORTSDIR}/www/py-plone.supermodel \
+ ${PYTHON_PKGNAMEPREFIX}plone.app.z3cform>=0:${PORTSDIR}/www/py-plone.app.z3cform \
+ ${PYTHON_PKGNAMEPREFIX}plone.autoform>=1.0:${PORTSDIR}/www/py-plone.autoform \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFCore>=0:${PORTSDIR}/devel/py-Products.CMFCore \
+ ${PYTHON_PKGNAMEPREFIX}Products.GenericSetup>=0:${PORTSDIR}/devel/py-Products.GenericSetup \
+ ${PYTHON_PKGNAMEPREFIX}Products.statusmessages>=0:${PORTSDIR}/devel/py-Products.statusmessages \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:${PORTSDIR}/textproc/py-zope.i18nmessageid \
+ ${PYTHON_PKGNAMEPREFIX}zope.dottedname>=0:${PORTSDIR}/devel/py-zope.dottedname
+
+DIST_SUBDIR= zope
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= easy_install
+#USE_ZOPE= yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name "*.orig" -delete
+
+.include <bsd.port.mk>