aboutsummaryrefslogtreecommitdiff
path: root/www/py-qt5-webchannel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-qt5-webchannel/Makefile')
-rw-r--r--www/py-qt5-webchannel/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/www/py-qt5-webchannel/Makefile b/www/py-qt5-webchannel/Makefile
index 5b765babbd99..d4e15a007a38 100644
--- a/www/py-qt5-webchannel/Makefile
+++ b/www/py-qt5-webchannel/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= webchannel
-PORTREVISION= 4
CATEGORIES= www devel python
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +10,7 @@ COMMENT= Python bindings for the Qt5 toolkit, QtWebChannel module
USES= python pyqt:5 qt:5
USE_PYQT= sip_build core_run gui_run network_run qml_run widgets_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= core declarative qmake_build gui network webchannel widgets
CONFIGURE_ARGS= --enable QtWebChannel \
@@ -23,7 +22,7 @@ OPTIONS_DEFAULT= API
OPTIONS_SUB= yes
API_DESC= Install QtWebChannel API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace