aboutsummaryrefslogtreecommitdiff
path: root/www/py-twistedWeb2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-twistedWeb2/Makefile')
-rw-r--r--www/py-twistedWeb2/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/py-twistedWeb2/Makefile b/www/py-twistedWeb2/Makefile
index 085fb764ce1f..d30420cd43eb 100644
--- a/www/py-twistedWeb2/Makefile
+++ b/www/py-twistedWeb2/Makefile
@@ -6,6 +6,7 @@
PORTNAME= twistedWeb2
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= www devel python
MASTER_SITES= http://twistedmatrix.com/downloads/Web2/ \
http://tmrc.mit.edu/mirror/twisted/Web2/
@@ -24,4 +25,9 @@ USE_BZIP2= yes
USE_PYTHON= 2.2+
USE_PYDISTUTILS= yes
+post-extract:
+ # temporal hack to work with Twisted 2.4
+ ${ECHO_CMD} "from twisted.python import versions" > ${WRKSRC}/twisted/web2/_version.py
+ ${ECHO_CMD} "version = versions.Version(__name__[:__name__.rfind('.')], 0, 1, 0)" >> ${WRKSRC}/twisted/web2/_version.py
+
.include <bsd.port.mk>