aboutsummaryrefslogtreecommitdiff
path: root/www/py-webware-component/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-webware-component/Makefile')
-rw-r--r--www/py-webware-component/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/py-webware-component/Makefile b/www/py-webware-component/Makefile
new file mode 100644
index 000000000000..6571c0669c99
--- /dev/null
+++ b/www/py-webware-component/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-webware-component
+# Date created: 2005-03-25
+# Whom: Choe, Cheng-Dae
+#
+# $FreeBSD$
+#
+
+PORTNAME= Component
+PORTVERSION= 0.1
+CATEGORIES= www python
+MASTER_SITES= http://www.webwareforpython.org/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}webware-
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= Webware servlet component extension
+
+RUN_DEPENDS= ${LOCALBASE}/share/webware/__init__.py:${PORTSDIR}/www/py-webware
+
+USE_PYTHON= yes
+
+do-build:
+ @${ECHO_MSG} -n ">> Compiling ..."
+ @${PYTHON_CMD} -c "import compileall; compileall.compile_dir('${WRKSRC}')"
+ @${ECHO_MSG} " [ DONE ]"
+
+do-install:
+ @${ECHO_CMD} -n ">> Installing ..."
+ @cd ${WRKSRC} && \
+ ${FIND} . -type d -exec ${MKDIR} "${PREFIX}/share/webware/${PORTNAME}/{}" \; && \
+ ${FIND} . -not -type d -exec ${INSTALL_DATA} "{}" "${PREFIX}/share/webware/${PORTNAME}/{}" \;
+ @${ECHO_MSG} " [ DONE ]"
+
+.include <bsd.port.mk>