aboutsummaryrefslogtreecommitdiff
path: root/www/pyweblib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/pyweblib/Makefile')
-rw-r--r--www/pyweblib/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/pyweblib/Makefile b/www/pyweblib/Makefile
new file mode 100644
index 000000000000..a9ae7fc2de2f
--- /dev/null
+++ b/www/pyweblib/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pyweblib
+# Date created: 22 March 2002
+# Whom: Oddbjorn Steffensen <oddbjorn@tricknology.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyweblib
+PORTVERSION= 1.1.0
+CATEGORIES= www
+MASTER_SITES= http://www.stroeder.com/pylib/PyWebLib/download/ \
+ http://www.tricknology.org/ports/
+
+MAINTAINER= oddbjorn@tricknology.org
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+USE_PYTHON= yes
+PYTHON_VERSION= python2.1
+WRKSRC= ${WRKDIR}/${DISTNAME:S=-src==}
+
+do-build:
+ cd ${WRKSRC} && python setup.py build
+
+do-install:
+ cd ${WRKSRC} && python setup.py install
+
+.include <bsd.port.mk>