aboutsummaryrefslogtreecommitdiff
path: root/www/reportmagic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/reportmagic/Makefile')
-rw-r--r--www/reportmagic/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/reportmagic/Makefile b/www/reportmagic/Makefile
index 9ca9ea8c0e07..0e01fcba3569 100644
--- a/www/reportmagic/Makefile
+++ b/www/reportmagic/Makefile
@@ -20,8 +20,7 @@ COMMENT= A web site statistics post-processor for Analog
RUN_DEPENDS= analog:${PORTSDIR}/www/analog \
${SITE_PERL}/GD/Graph3d.pm:${PORTSDIR}/graphics/p5-GD-Graph3d \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+ ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles
WRKSRC= ${WRKDIR}/${DISTNAME}
NO_BUILD= YES
@@ -36,4 +35,10 @@ post-install:
@${ECHO} "using Report Magic."
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>