aboutsummaryrefslogtreecommitdiff
path: root/www/resin3
diff options
context:
space:
mode:
Diffstat (limited to 'www/resin3')
-rw-r--r--www/resin3/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 11fb5008784e..923e28a74090 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= resin
PORTVERSION= 3.0.21
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= http://www.caucho.com/download/
@@ -114,6 +115,11 @@ SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
-e "s|%%WRKDIR%%|${WRKDIR}|g" \
-e "s|%%WRKSRC%%|${WRKSRC}|g"
+# Avoid build error on 64-bit architectures
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+CFLAGS+= -fPIC
+.endif
+
post-patch:
@${REINPLACE_CMD} ${SUBSTITUTIONS} ${REINPLACE_FILES}
@for FILE in ${REPLACE_FILES} ; do \