aboutsummaryrefslogtreecommitdiff
path: root/www/rt40
diff options
context:
space:
mode:
Diffstat (limited to 'www/rt40')
-rw-r--r--www/rt40/Makefile4
-rw-r--r--www/rt40/Makefile.cpan24
-rw-r--r--www/rt40/distinfo6
-rw-r--r--www/rt40/files/patch-Makefile.in22
-rw-r--r--www/rt40/files/patch-config.layout7
-rw-r--r--www/rt40/pkg-plist29
6 files changed, 58 insertions, 34 deletions
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index 6a7f2450c82e..e1134bd89d1b 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -12,7 +12,7 @@
# o install a sample into etc/apache22/Includes
PORTNAME= rt
-PORTVERSION= 3.8.7
+PORTVERSION= 3.8.8
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
ftp://ftp.eu.uu.net/pub/unix/ticketing/rt/release/
@@ -132,7 +132,7 @@ IGNORE= you must choose a database backend
IGNORE= options WITH_MODPERL and WITH_MODPERL2 are mutually exclusive
.endif
-RT_ETC_PATH?= ${LOCALBASE}/etc/${PORTNAME}38
+RT_ETC_PATH?= ${PREFIX}/etc/${PORTNAME}38
RT_LAYOUT= FreeBSD
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}38
diff --git a/www/rt40/Makefile.cpan b/www/rt40/Makefile.cpan
index f84723ae63fa..bf451a6f7314 100644
--- a/www/rt40/Makefile.cpan
+++ b/www/rt40/Makefile.cpan
@@ -5,6 +5,8 @@
### Pod::Usage 1.33 core
### Scalar::Util 1.18 core
### Text::ParseWords 3.24 core
+### Term::ReadLine core
+### Term::ReadKey core
CLI_DEPS= p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-Getopt-Long>=2.24:${PORTSDIR}/devel/p5-Getopt-Long \
@@ -12,7 +14,7 @@ CLI_DEPS= p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-ReadLine-Perl>=1.0302:${PORTSDIR}/devel/p5-ReadLine-Perl \
p5-Net-SSLeay>=1.35:${PORTSDIR}/security/p5-Net-SSLeay
-CORE_DEPS= p5-Encode>=2.13:${PORTSDIR}/converters/p5-Encode \
+CORE_DEPS= p5-Encode>=2.21:${PORTSDIR}/converters/p5-Encode \
p5-Class-ReturnValue>=0.55:${PORTSDIR}/devel/p5-Class-ReturnValue \
p5-Text-Quoted>=2.05:${PORTSDIR}/textproc/p5-Text-Quoted \
p5-CSS-Squish>=0.07:${PORTSDIR}/textproc/p5-CSS-Squish \
@@ -22,18 +24,18 @@ CORE_DEPS= p5-Encode>=2.13:${PORTSDIR}/converters/p5-Encode \
p5-File-Temp>=0.18:${PORTSDIR}/devel/p5-File-Temp \
p5-Tree-Simple>=1.04:${PORTSDIR}/devel/p5-Tree-Simple \
p5-HTML-Scrubber>=0.08:${PORTSDIR}/www/p5-HTML-Scrubber \
- p5-DBIx-SearchBuilder>=1.53:${PORTSDIR}/databases/p5-DBIx-SearchBuilder \
+ p5-DBIx-SearchBuilder>=1.54:${PORTSDIR}/databases/p5-DBIx-SearchBuilder \
p5-Mail-Tools>=1.57:${PORTSDIR}/mail/p5-Mail-Tools \
p5-File-ShareDir>=1.00:${PORTSDIR}/devel/p5-File-ShareDir \
p5-Cache-Simple-TimedExpiry>=0.27:${PORTSDIR}/devel/p5-Cache-Simple-TimedExpiry \
- ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Text-Template>=1.44:${PORTSDIR}/textproc/p5-Text-Template \
+ p5-Log-Dispatch>=2.0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Locale-Maketext>=1.06:${PORTSDIR}/devel/p5-Locale-Maketext \
+ p5-Locale-Maketext-Lexicon>=0.32:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
+ p5-MIME-Tools>=5.425:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Email/Address.pm:${PORTSDIR}/mail/p5-Email-Address \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/Locale/Maketext/Lexicon.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
- ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext \
- ${SITE_PERL}/Text/Template.pm:${PORTSDIR}/textproc/p5-Text-Template \
${SITE_PERL}/Calendar/Simple.pm:${PORTSDIR}/devel/p5-Calendar-Simple \
${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common \
${SITE_PERL}/Locale/Maketext/Fuzzy.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Fuzzy \
@@ -57,7 +59,11 @@ DEV_DEPS= ${SITE_PERL}/Log/Dispatch/Perl.pm:${PORTSDIR}/devel/p5-Log-Dispatch-Pe
${SITE_PERL}/Test/Expect.pm>=0.31:${PORTSDIR}/devel/p5-Test-Expect \
${SITE_PERL}/Test/WWW/Mechanize.pm>=1.04:${PORTSDIR}/devel/p5-Test-WWW-Mechanize \
${SITE_PERL}/Test/HTTP/Server/Simple.pm>=0.09:${PORTSDIR}/www/p5-Test-HTTP-Server-Simple \
- ${SITE_PERL}/Test/Simple.pm>=0.77:${PORTSDIR}/devel/p5-Test-Simple
+ ${SITE_PERL}/Test/Simple.pm>=0.77:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
+ ${SITE_PERL}/Test/MockTime.pm:${PORTSDIR}/devel/p5-Test-MockTime \
+ ${SITE_PERL}/HTTP/Server/Simple/Mason.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple-Mason
GD_DEPS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
@@ -67,6 +73,7 @@ GPG_DEPS= ${SITE_PERL}/${PERL_ARCH}/PerlIO/eol.pm:${PORTSDIR}/devel/p5-PerlIO-eo
${SITE_PERL}/GnuPG/Interface.pm:${PORTSDIR}/security/p5-GnuPG-Interface
GRAPHVIZ_DEPS= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
+ ${SITE_PERL}/IPC/Run/SafeHandles.pm:${PORTSDIR}/devel/p5-IPC-Run-SafeHandles \
${SITE_PERL}/GraphViz.pm:${PORTSDIR}/graphics/p5-GraphViz
ICAL_DEPS= ${SITE_PERL}/Data/ICal.pm:${PORTSDIR}/deskutils/p5-Data-ICal
@@ -84,7 +91,6 @@ MASON_DEPS= p5-Storable>=2.08:${PORTSDIR}/devel/p5-Storable \
p5-Apache-Session>=1.53:${PORTSDIR}/www/p5-Apache-Session \
p5-Devel-StackTrace>=1.19:${PORTSDIR}/devel/p5-Devel-StackTrace \
p5-CGI.pm>=1.20:${PORTSDIR}/www/p5-CGI.pm \
- p5-Text-WikiFormat>=0.76:${PORTSDIR}/textproc/p5-Text-WikiFormat \
p5-XML-RSS>=1.05:${PORTSDIR}/textproc/p5-XML-RSS \
p5-HTML-Mason>=1.36:${PORTSDIR}/www/p5-HTML-Mason
diff --git a/www/rt40/distinfo b/www/rt40/distinfo
index c35014a5e9bd..3643a229432d 100644
--- a/www/rt40/distinfo
+++ b/www/rt40/distinfo
@@ -1,3 +1,3 @@
-MD5 (rt-3.8.7.tar.gz) = 1e269e88cb03a94f7992b115d4d0828a
-SHA256 (rt-3.8.7.tar.gz) = dacc4392cbb3987a5ac6ba25bfe9b3348cd9b5485d08c448a21aae4d87064f30
-SIZE (rt-3.8.7.tar.gz) = 3372703
+MD5 (rt-3.8.8.tar.gz) = de062840ce6e2fdb323d77dddf8ff485
+SHA256 (rt-3.8.8.tar.gz) = d3932febc5b3fa1da1168713f305a095ea6b40dd22d508849471e6637ba04c02
+SIZE (rt-3.8.8.tar.gz) = 5109734
diff --git a/www/rt40/files/patch-Makefile.in b/www/rt40/files/patch-Makefile.in
index b622e9aa2416..0458726ae855 100644
--- a/www/rt40/files/patch-Makefile.in
+++ b/www/rt40/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2009-12-04 17:30:18.000000000 -0500
-+++ Makefile.in 2009-12-04 17:33:01.000000000 -0500
+--- Makefile.in.orig 2010-05-05 13:09:21.000000000 -0700
++++ Makefile.in 2010-08-05 13:11:47.000000000 -0700
@@ -58,7 +58,7 @@
CONFIG_FILE_PATH = @CONFIG_FILE_PATH_R@
@@ -9,28 +9,28 @@
RT_VERSION_MAJOR = @RT_VERSION_MAJOR@
-@@ -107,7 +107,7 @@
- RT_VAR_PATH = @RT_VAR_PATH_R@
+@@ -108,7 +108,7 @@
RT_DOC_PATH = @RT_DOC_PATH_R@
+ RT_FONT_PATH = @RT_FONT_PATH_R@
RT_LOCAL_PATH = @RT_LOCAL_PATH_R@
-LOCAL_PLUGIN_PATH = @RT_LOCAL_PATH_R@/plugins
+LOCAL_PLUGIN_PATH = @RT_LOCAL_PATH_R@/share/rt38/plugins
LOCAL_ETC_PATH = @LOCAL_ETC_PATH_R@
LOCAL_LIB_PATH = @LOCAL_LIB_PATH_R@
LOCAL_LEXICON_PATH = @LOCAL_LEXICON_PATH_R@
-@@ -282,9 +282,9 @@
+@@ -286,9 +286,9 @@
@echo " $(RT_SBIN_PATH)/rt-setup-database --dba $(DB_DBA) --prompt-for-dba-password --action upgrade"
-upgrade: testdeps config-install dirs files-install fixperms upgrade-instruct
+upgrade: config-install dirs files-install fixperms upgrade-instruct
--upgrade-noclobber: config-install dirs libs-install html-install bin-install local-install doc-install fixperms
-+upgrade-noclobber: config-install dirs libs-install html-install bin-install local-install doc-install
+-upgrade-noclobber: config-install dirs libs-install html-install bin-install local-install doc-install font-install fixperms
++upgrade-noclobber: config-install dirs libs-install html-install bin-install local-install doc-install font-install
# {{{ dependencies
-@@ -302,13 +302,6 @@
+@@ -306,13 +306,6 @@
# {{{ fixperms
fixperms:
@@ -44,15 +44,15 @@
chmod $(RT_READABLE_DIR_MODE) $(DESTDIR)$(RT_BIN_PATH)
chmod 0755 $(DESTDIR)$(RT_ETC_PATH)
-@@ -362,9 +355,9 @@
+@@ -367,9 +360,9 @@
$(INSTALL) -m 0755 -d $(DESTDIR)$(LOCAL_LEXICON_PATH)
# }}}
-install: testdeps config-install dirs files-install fixperms instruct
+install: config-install dirs files-install fixperms instruct
--files-install: libs-install etc-install config-install bin-install sbin-install html-install local-install doc-install
-+files-install: libs-install etc-install config-install bin-install sbin-install html-install doc-install
+-files-install: libs-install etc-install config-install bin-install sbin-install html-install local-install doc-install font-install
++files-install: libs-install etc-install config-install bin-install sbin-install html-install doc-install font-install
config-install:
@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -o $(BIN_OWNER) -g $(RTGROUP) -d $(DESTDIR)$(CONFIG_FILE_PATH)
diff --git a/www/rt40/files/patch-config.layout b/www/rt40/files/patch-config.layout
index 22dac01d4d98..2e7802fbb112 100644
--- a/www/rt40/files/patch-config.layout
+++ b/www/rt40/files/patch-config.layout
@@ -1,6 +1,6 @@
---- config.layout.orig 2010-04-01 14:52:01.000000000 +0200
-+++ config.layout 2010-04-01 14:54:23.000000000 +0200
-@@ -88,26 +88,27 @@
+--- config.layout.orig 2010-08-22 04:48:20.000000000 +0200
++++ config.layout 2010-08-22 04:50:50.000000000 +0200
+@@ -91,27 +91,28 @@
</Layout>
<Layout FreeBSD>
@@ -17,6 +17,7 @@
datadir: ${prefix}/share+
htmldir: ${datadir}/html
+ sharedir: ${prefix}/share+
+ fontdir: ${datadir}/fonts
manualdir: ${prefix}/share/doc+
logfiledir: /var/log
localstatedir: /var/run+
diff --git a/www/rt40/pkg-plist b/www/rt40/pkg-plist
index 098998fdc2cf..cbdc08f7656e 100644
--- a/www/rt40/pkg-plist
+++ b/www/rt40/pkg-plist
@@ -1,6 +1,7 @@
@comment $FreeBSD$
@unexec if cmp -s %D/etc/rt38/RT_SiteConfig.pm %D/etc/rt38/RT_SiteConfig.pm-dist; then rm -f %D/etc/rt38/RT_SiteConfig.pm; fi
@exec [ -f %D/etc/rt38/RT_SiteConfig.pm ] || cp %D/rt38/RT_SiteConfig.pm-dist %D/etc/rt38/RT_SiteConfig.pm
+bin/fastcgi_server
bin/mason_handler.fcgi
bin/mason_handler.scgi
bin/mason_handler.svc
@@ -125,9 +126,11 @@ etc/rt38/schema.mysql-4.1
%%SITE_PERL%%/RT/I18N/ja.po
%%SITE_PERL%%/RT/I18N/nb.po
%%SITE_PERL%%/RT/I18N/nl.po
+%%SITE_PERL%%/RT/I18N/nn.po
%%SITE_PERL%%/RT/I18N/pl.po
%%SITE_PERL%%/RT/I18N/pt.po
%%SITE_PERL%%/RT/I18N/pt_BR.po
+%%SITE_PERL%%/RT/I18N/pt_PT.po
%%SITE_PERL%%/RT/I18N/rt.pot
%%SITE_PERL%%/RT/I18N/ru.pm
%%SITE_PERL%%/RT/I18N/ru.po
@@ -274,6 +277,9 @@ sbin/rt-shredder
sbin/rt-test-dependencies
sbin/rt-validator
%%PORTDOCS%%%%DOCSDIR%%/README
+share/rt38/fonts/Droid.README
+share/rt38/fonts/DroidSans.ttf
+share/rt38/fonts/DroidSansFallback.ttf
share/rt38/html/Admin/CustomFields/GroupRights.html
share/rt38/html/Admin/CustomFields/Modify.html
share/rt38/html/Admin/CustomFields/Objects.html
@@ -432,6 +438,7 @@ share/rt38/html/Elements/EditCustomFieldSelect
share/rt38/html/Elements/EditCustomFieldText
share/rt38/html/Elements/EditCustomFieldWikitext
share/rt38/html/Elements/EditLinks
+share/rt38/html/Elements/EditPassword
share/rt38/html/Elements/EditTimeValue
share/rt38/html/Elements/EmailInput
share/rt38/html/Elements/Error
@@ -463,6 +470,7 @@ share/rt38/html/Elements/QueryString
share/rt38/html/Elements/QueueSummary
share/rt38/html/Elements/QuickCreate
share/rt38/html/Elements/Quicksearch
+share/rt38/html/Elements/RT__CustomField/ColumnMap
share/rt38/html/Elements/RT__Group/ColumnMap
share/rt38/html/Elements/RT__Queue/ColumnMap
share/rt38/html/Elements/RT__Scrip/ColumnMap
@@ -487,13 +495,13 @@ share/rt38/html/Elements/SelectLinkType
share/rt38/html/Elements/SelectMatch
share/rt38/html/Elements/SelectNewTicketQueue
share/rt38/html/Elements/SelectOwner
+share/rt38/html/Elements/SelectPriority
share/rt38/html/Elements/SelectQueue
share/rt38/html/Elements/SelectResultsPerPage
share/rt38/html/Elements/SelectSortOrder
share/rt38/html/Elements/SelectStatus
share/rt38/html/Elements/SelectTicketSortBy
share/rt38/html/Elements/SelectTicketTypes
-share/rt38/html/Elements/SelectPriority
share/rt38/html/Elements/SelectTimeUnits
share/rt38/html/Elements/SelectTimezone
share/rt38/html/Elements/SelectUsers
@@ -507,6 +515,7 @@ share/rt38/html/Elements/ShowCustomFields
share/rt38/html/Elements/ShowLink
share/rt38/html/Elements/ShowLinks
share/rt38/html/Elements/ShowMemberships
+share/rt38/html/Elements/ShowRelationLabel
share/rt38/html/Elements/ShowSearch
share/rt38/html/Elements/ShowUser
share/rt38/html/Elements/ShowUserConcise
@@ -908,12 +917,14 @@ share/rt38/html/NoAuth/css/3.5-default/ticket.css
share/rt38/html/NoAuth/css/3.5-default/titlebox.css
share/rt38/html/NoAuth/css/3.5-default/transactions.css
share/rt38/html/NoAuth/css/autohandler
+share/rt38/html/NoAuth/css/base/misc.css
share/rt38/html/NoAuth/css/dhandler
share/rt38/html/NoAuth/css/print.css
share/rt38/html/NoAuth/css/web2/InHeader
share/rt38/html/NoAuth/css/web2/admin.css
share/rt38/html/NoAuth/css/web2/base.css
share/rt38/html/NoAuth/css/web2/boxes.css
+share/rt38/html/NoAuth/css/web2/collection.css
share/rt38/html/NoAuth/css/web2/forms.css
share/rt38/html/NoAuth/css/web2/images/dhandler
share/rt38/html/NoAuth/css/web2/images/source/background-gradient.png
@@ -976,6 +987,7 @@ share/rt38/html/NoAuth/js/scriptaculous/effects.js
share/rt38/html/NoAuth/js/scriptaculous/scriptaculous.js
share/rt38/html/NoAuth/js/titlebox-state.js
share/rt38/html/NoAuth/js/util.js
+share/rt38/html/NoAuth/rss/dhandler
share/rt38/html/Prefs/Elements/Tabs
share/rt38/html/Prefs/MyRT.html
share/rt38/html/Prefs/Other.html
@@ -1027,6 +1039,7 @@ share/rt38/html/Search/Elements/PickBasics
share/rt38/html/Search/Elements/PickCFs
share/rt38/html/Search/Elements/PickCriteria
share/rt38/html/Search/Elements/ResultViews
+share/rt38/html/Search/Elements/ResultsRSSView
share/rt38/html/Search/Elements/SearchPrivacy
share/rt38/html/Search/Elements/SearchesForObject
share/rt38/html/Search/Elements/SelectAndOr
@@ -1146,10 +1159,11 @@ share/rt38/html/autohandler
share/rt38/html/dhandler
share/rt38/html/index.html
share/rt38/html/l
-@dirrm share/rt38/etc
+@dirrmtry www/rt38
+@dirrm share/rt38/po
@exec mkdir -p %D/share/rt38/plugins
@dirrm share/rt38/plugins
-@dirrm share/rt38/po
+@dirrm share/rt38/lib
@dirrm share/rt38/html/Widgets/Form
@dirrm share/rt38/html/Widgets
@dirrm share/rt38/html/User/Groups
@@ -1184,6 +1198,7 @@ share/rt38/html/l
@dirrm share/rt38/html/REST
@dirrm share/rt38/html/Prefs/Elements
@dirrm share/rt38/html/Prefs
+@dirrm share/rt38/html/NoAuth/rss
@dirrm share/rt38/html/NoAuth/js/scriptaculous
@dirrm share/rt38/html/NoAuth/js/prototype
@dirrm share/rt38/html/NoAuth/js/IE7
@@ -1194,9 +1209,11 @@ share/rt38/html/l
@dirrm share/rt38/html/NoAuth/css/web2/images/source
@dirrm share/rt38/html/NoAuth/css/web2/images
@dirrm share/rt38/html/NoAuth/css/web2
+@dirrm share/rt38/html/NoAuth/css/base
@dirrm share/rt38/html/NoAuth/css/3.5-default
@dirrm share/rt38/html/NoAuth/css/3.4-compat
@dirrm share/rt38/html/NoAuth/css
+@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/wsc
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/skins/silver/images
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/skins/silver
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/skins/office2003/images
@@ -1237,7 +1254,6 @@ share/rt38/html/l
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/css/images
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/css/behaviors
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/css
-@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/wsc
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/_source/internals
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/_source/commandclasses
@dirrm share/rt38/html/NoAuth/RichText/FCKeditor/editor/_source/classes
@@ -1257,6 +1273,7 @@ share/rt38/html/l
@dirrm share/rt38/html/Elements/RT__Scrip
@dirrm share/rt38/html/Elements/RT__Queue
@dirrm share/rt38/html/Elements/RT__Group
+@dirrm share/rt38/html/Elements/RT__CustomField
@dirrm share/rt38/html/Elements/GnuPG
@dirrm share/rt38/html/Elements/CollectionAsTable
@dirrm share/rt38/html/Elements
@@ -1283,7 +1300,8 @@ share/rt38/html/l
@dirrm share/rt38/html/Admin/CustomFields
@dirrm share/rt38/html/Admin
@dirrm share/rt38/html
-@dirrm share/rt38/lib
+@dirrm share/rt38/fonts
+@dirrm share/rt38/etc
@dirrm share/rt38
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%SITE_PERL%%/RT/URI
@@ -1312,4 +1330,3 @@ share/rt38/html/l
@dirrm %%SITE_PERL%%/RT/Action
@dirrm %%SITE_PERL%%/RT
@dirrm etc/rt38
-@dirrmtry www/rt38