aboutsummaryrefslogtreecommitdiff
path: root/www/screem-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/screem-devel/Makefile')
-rw-r--r--www/screem-devel/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/www/screem-devel/Makefile b/www/screem-devel/Makefile
index 5c200b79c8db..b6693c138608 100644
--- a/www/screem-devel/Makefile
+++ b/www/screem-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= screem
-PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTVERSION= 0.10.1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,14 +14,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= coop9211@uidaho.edu
COMMENT= Nice GNOME/GTK-based HTML editor
-LIB_DEPENDS+= neon.24:${PORTSDIR}/www/neon
+LIB_DEPENDS+= neon.24:${PORTSDIR}/www/neon \
+ croco.2:${PORTSDIR}/textproc/libcroco
USE_GMAKE= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml \
- gtksourceview
+ gtksourceview lthack intlhack
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
@@ -38,10 +38,8 @@ CONFIGURE_ARGS+= --without-included-neon
# --with-neon="${LOCALBASE}/lib"
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|\@GNOME_DATA_PREFIX\@|\$$\(datadir\)|g'
+ @${REINPLACE_CMD} -e 's|\$${DATADIRNAME}/\$${PACKAGE}/pixmaps|\$${DATADIRNAME}/gnome/\$${PACKAGE}/pixmaps|g' \
+ ${WRKSRC}/configure
post-configure:
@${REINPLACE_CMD} -e 's|\/\* #undef HAVE_LIMITS_H \*\/|#define HAVE_LIMITS_H 1|g' ${WRKSRC}/config.h