aboutsummaryrefslogtreecommitdiff
path: root/www/screem
diff options
context:
space:
mode:
Diffstat (limited to 'www/screem')
-rw-r--r--www/screem/Makefile31
-rw-r--r--www/screem/distinfo2
-rw-r--r--www/screem/files/patch-ab64
-rw-r--r--www/screem/pkg-plist201
4 files changed, 217 insertions, 81 deletions
diff --git a/www/screem/Makefile b/www/screem/Makefile
index 0091c8145d77..0cd483431eb0 100644
--- a/www/screem/Makefile
+++ b/www/screem/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= screem
-PORTVERSION= 0.2.1
+PORTVERSION= 0.2.8
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.screem.org/src/
@@ -14,18 +14,29 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= glade.4:${PORTSDIR}/devel/libglade
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
+ xml.5:${PORTSDIR}/textproc/libxml \
+ glade.4:${PORTSDIR}/devel/libglade \
+ guile.6:${PORTSDIR}/lang/guile \
+ wwwcore.1:${PORTSDIR}/www/libwww \
+ Xpm.4:${PORTSDIR}/graphics/xpm
+RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
-LIBGLADE_CONFIG?= ${LOCALBASE}/bin/libglade-config
-GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_X_PREFIX= yes
-CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
-CONFIGURE_ARGS= --with-gnome=${PREFIX}/include --prefix=${PREFIX} \
- --with-gtk-exec-prefix=${PREFIX} --with-gtk=${PREFIX} \
- --with-libglade-config=${LIBGLADE_CONFIG} \
- --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share --libdir=${PREFIX}/share
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share \
+ --libdir=${PREFIX}/share
.include <bsd.port.mk>
diff --git a/www/screem/distinfo b/www/screem/distinfo
index 9f4b75f98cc3..e43c2356e166 100644
--- a/www/screem/distinfo
+++ b/www/screem/distinfo
@@ -1 +1 @@
-MD5 (screem-0.2.1.tar.gz) = 37a39c59e34399a13455b759e03e8eeb
+MD5 (screem-0.2.8.tar.gz) = f8445beb528a6a4dbec033bf917be8f5
diff --git a/www/screem/files/patch-ab b/www/screem/files/patch-ab
index dbaa9196f0dd..7482922efb60 100644
--- a/www/screem/files/patch-ab
+++ b/www/screem/files/patch-ab
@@ -1,74 +1,34 @@
---- configure Mon Jan 3 09:33:01 2000
-+++ configure.new Sat Mar 18 16:23:46 2000
-@@ -1922,8 +1922,8 @@
- LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
- LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
- DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
--${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
--$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
-+${CONFIG_SHELL-/bin/sh} /usr/local/share/libtool/ltconfig --no-reexec \
-+$libtool_flags --no-verify --disable-ltlibs /usr/local/share/libtool/ltmain.sh $host \
- || { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-
- # Reload cache, that may have been modified by ltconfig
-@@ -1937,7 +1937,7 @@
-
-
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="/usr/local/share/libtool/ltconfig --disable-ltlibs /usr/local/share/libtool/ltmain.sh"
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -2405,6 +2405,7 @@
- fi
-
-
-+if false; then
- PTHREAD_LIB=""
- echo $ac_n "checking for pthread_create in -lpthread""... $ac_c" 1>&6
- echo "configure:2411: checking for pthread_create in -lpthread" >&5
-@@ -2482,6 +2483,9 @@
+--- configure.orig Mon Jul 17 21:51:46 2000
++++ configure Fri Jul 21 12:13:37 2000
+@@ -2763,14 +2763,14 @@
PTHREAD_LIB="-lpthreads"
else
echo "$ac_t""no" 1>&6
-+fi
-+fi
-+fi
- echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
- echo "configure:2487: checking for pthread_create in -lc_r" >&5
+-echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+-echo "configure:2768: checking for pthread_create in -lc_r" >&5
++echo $ac_n "checking for pthread_create in -pthread""... $ac_c" 1>&6
++echo "configure:2768: checking for pthread_create in -pthread" >&5
ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
-@@ -2489,7 +2493,7 @@
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lc_r $LIBS"
+LIBS="-pthread $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 2495 "configure"
+ #line 2776 "configure"
#include "confdefs.h"
-@@ -2517,7 +2521,7 @@
+@@ -2798,7 +2798,8 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
- PTHREAD_LIB="-lc_r"
+ PTHREAD_LIB="-pthread"
++ CFLAGS="$CFLAGS -D_REENTRANT -D_THREAD_SAFE"
else
echo "$ac_t""no" 1>&6
echo $ac_n "checking for pthread_create""... $ac_c" 1>&6
-@@ -2571,11 +2575,6 @@
-
- fi
-
--
--fi
--
--
--fi
-
-
-
-@@ -5882,7 +5881,7 @@
+@@ -6296,7 +6297,7 @@
cat conftest.$ac_ext >&5
rm -rf conftest*
CATOBJEXT=.mo
diff --git a/www/screem/pkg-plist b/www/screem/pkg-plist
index 5079f5fb0f17..f15e8af18151 100644
--- a/www/screem/pkg-plist
+++ b/www/screem/pkg-plist
@@ -1,43 +1,208 @@
bin/screem
+share/gnome/apps/Development/screem.desktop
share/gnome/mc/templates/screem.desktop
share/gnome/mime-info/screem.keys
share/gnome/mime-info/screem.mime
share/gnome/pixmaps/screem.png
+share/gnome/pixmaps/screem/broken.xpm
+share/gnome/pixmaps/screem/browser.xpm
+share/gnome/pixmaps/screem/button.xpm
+share/gnome/pixmaps/screem/checkbutton.xpm
+share/gnome/pixmaps/screem/dir-close.xpm
+share/gnome/pixmaps/screem/dir-open.xpm
+share/gnome/pixmaps/screem/entry.xpm
+share/gnome/pixmaps/screem/fixed.xpm
+share/gnome/pixmaps/screem/gallery.xpm
+share/gnome/pixmaps/screem/gnome-fileentry.xpm
+share/gnome/pixmaps/screem/image.xpm
+share/gnome/pixmaps/screem/link.xpm
+share/gnome/pixmaps/screem/noicon.xpm
+share/gnome/pixmaps/screem/optionmenu.xpm
+share/gnome/pixmaps/screem/preview.xpm
+share/gnome/pixmaps/screem/radiobutton.xpm
+share/gnome/pixmaps/screem/splash/1.png
+share/gnome/pixmaps/screem/splash/2.png
+share/gnome/pixmaps/screem/splash/3.png
+share/gnome/pixmaps/screem/splash/4.png
+share/gnome/pixmaps/screem/text.xpm
share/locale/de/LC_MESSAGES/screem.mo
share/locale/fr/LC_MESSAGES/screem.mo
+share/locale/it/LC_MESSAGES/screem.mo
+share/locale/ja/LC_MESSAGES/screem.mo
share/locale/pl/LC_MESSAGES/screem.mo
+share/locale/ru/LC_MESSAGES/screem.mo
+share/screem/frames/style1.html
share/screem/glade/css.glade
-share/screem/glade/extern_browsers.glade
+share/screem/glade/entityWizard.glade
+share/screem/glade/formWizard.glade
+share/screem/glade/frameWizard.glade
share/screem/glade/imageWizard.glade
share/screem/glade/linkWizard.glade
-share/screem/glade/pagedruid.glade
-share/screem/glade/preferences.glade
-share/screem/glade/site_settings.glade
-share/screem/glade/sitedruid.glade
-share/screem/glade/sitetemplate.glade
-share/screem/glade/todo.glade
+share/screem/glade/screem.glade
+share/screem/glade/uploadwizard.glade
+share/screem/hints/screem_hints.txt
+share/screem/htmlhelp/alist.html
+share/screem/htmlhelp/attrs.html
+share/screem/htmlhelp/aural.css
+share/screem/htmlhelp/block.html
+share/screem/htmlhelp/block/address.html
+share/screem/htmlhelp/block/blockquote.html
+share/screem/htmlhelp/block/center.html
+share/screem/htmlhelp/block/div.html
+share/screem/htmlhelp/block/h1.html
+share/screem/htmlhelp/block/h2.html
+share/screem/htmlhelp/block/h3.html
+share/screem/htmlhelp/block/h4.html
+share/screem/htmlhelp/block/h5.html
+share/screem/htmlhelp/block/h6.html
+share/screem/htmlhelp/block/hr.html
+share/screem/htmlhelp/block/index.html
+share/screem/htmlhelp/block/isindex.html
+share/screem/htmlhelp/block/noscript.html
+share/screem/htmlhelp/block/p.html
+share/screem/htmlhelp/block/pre.html
+share/screem/htmlhelp/deprecated.html
+share/screem/htmlhelp/entities/index.html
+share/screem/htmlhelp/entities/latin1.html
+share/screem/htmlhelp/entities/special.html
+share/screem/htmlhelp/entities/symbols.html
+share/screem/htmlhelp/fontstyle/b.html
+share/screem/htmlhelp/fontstyle/big.html
+share/screem/htmlhelp/fontstyle/i.html
+share/screem/htmlhelp/fontstyle/index.html
+share/screem/htmlhelp/fontstyle/s.html
+share/screem/htmlhelp/fontstyle/small.html
+share/screem/htmlhelp/fontstyle/strike.html
+share/screem/htmlhelp/fontstyle/tt.html
+share/screem/htmlhelp/fontstyle/u.html
+share/screem/htmlhelp/forms/button.html
+share/screem/htmlhelp/forms/fieldset.html
+share/screem/htmlhelp/forms/form.html
+share/screem/htmlhelp/forms/index.html
+share/screem/htmlhelp/forms/input.html
+share/screem/htmlhelp/forms/label.html
+share/screem/htmlhelp/forms/legend.html
+share/screem/htmlhelp/forms/optgroup.html
+share/screem/htmlhelp/forms/option.html
+share/screem/htmlhelp/forms/select.html
+share/screem/htmlhelp/forms/textarea.html
+share/screem/htmlhelp/frames/frame.html
+share/screem/htmlhelp/frames/frameset.html
+share/screem/htmlhelp/frames/index.html
+share/screem/htmlhelp/frames/noframes.html
+share/screem/htmlhelp/head/base.html
+share/screem/htmlhelp/head/head.html
+share/screem/htmlhelp/head/index.html
+share/screem/htmlhelp/head/link.html
+share/screem/htmlhelp/head/meta.html
+share/screem/htmlhelp/head/style.html
+share/screem/htmlhelp/head/title.html
+share/screem/htmlhelp/html/body.html
+share/screem/htmlhelp/html/doctype.html
+share/screem/htmlhelp/html/html.html
+share/screem/htmlhelp/html/index.html
+share/screem/htmlhelp/index.html
+share/screem/htmlhelp/inline.html
+share/screem/htmlhelp/lists/dd.html
+share/screem/htmlhelp/lists/dir.html
+share/screem/htmlhelp/lists/dl.html
+share/screem/htmlhelp/lists/dt.html
+share/screem/htmlhelp/lists/index.html
+share/screem/htmlhelp/lists/li.html
+share/screem/htmlhelp/lists/menu.html
+share/screem/htmlhelp/lists/ol.html
+share/screem/htmlhelp/lists/ul.html
+share/screem/htmlhelp/new.html
+share/screem/htmlhelp/olist.html
+share/screem/htmlhelp/phrase/abbr.html
+share/screem/htmlhelp/phrase/acronym.html
+share/screem/htmlhelp/phrase/cite.html
+share/screem/htmlhelp/phrase/code.html
+share/screem/htmlhelp/phrase/del.html
+share/screem/htmlhelp/phrase/dfn.html
+share/screem/htmlhelp/phrase/em.html
+share/screem/htmlhelp/phrase/index.html
+share/screem/htmlhelp/phrase/ins.html
+share/screem/htmlhelp/phrase/kbd.html
+share/screem/htmlhelp/phrase/samp.html
+share/screem/htmlhelp/phrase/strong.html
+share/screem/htmlhelp/phrase/var.html
+share/screem/htmlhelp/special/a.html
+share/screem/htmlhelp/special/applet.html
+share/screem/htmlhelp/special/area.html
+share/screem/htmlhelp/special/basefont.html
+share/screem/htmlhelp/special/bdo.html
+share/screem/htmlhelp/special/br.html
+share/screem/htmlhelp/special/font.html
+share/screem/htmlhelp/special/iframe.html
+share/screem/htmlhelp/special/img.html
+share/screem/htmlhelp/special/index.html
+share/screem/htmlhelp/special/map.html
+share/screem/htmlhelp/special/object.html
+share/screem/htmlhelp/special/param.html
+share/screem/htmlhelp/special/q.html
+share/screem/htmlhelp/special/script.html
+share/screem/htmlhelp/special/span.html
+share/screem/htmlhelp/special/sub.html
+share/screem/htmlhelp/special/sup.html
+share/screem/htmlhelp/structure.html
+share/screem/htmlhelp/style.css
+share/screem/htmlhelp/tables/caption.html
+share/screem/htmlhelp/tables/col.html
+share/screem/htmlhelp/tables/colgroup.html
+share/screem/htmlhelp/tables/index.html
+share/screem/htmlhelp/tables/table.html
+share/screem/htmlhelp/tables/tbody.html
+share/screem/htmlhelp/tables/td.html
+share/screem/htmlhelp/tables/tfoot.html
+share/screem/htmlhelp/tables/th.html
+share/screem/htmlhelp/tables/thead.html
+share/screem/htmlhelp/tables/tr.html
+share/screem/htmlhelp/values.html
+share/screem/htmlhelp/wdglogo-small.gif
+share/screem/htmlhelp/wdglogo1.gif
share/screem/plugins/colourWizard.so
share/screem/plugins/cssWizard.so
share/screem/plugins/entityWizard.so
-share/screem/plugins/externBrowsers.so
+share/screem/plugins/formWizard.so
+share/screem/plugins/frameWizard.so
share/screem/plugins/galleryWizard.so
share/screem/plugins/imageWizard.so
share/screem/plugins/linkWizard.so
share/screem/plugins/mailWizard.so
+share/screem/plugins/script.scm
share/screem/plugins/ssiWizard.so
share/screem/plugins/tableWizard.so
share/screem/plugins/uploadWizard.so
+share/screem/resources/Images/made.jpg
share/screem/screem.tagtree
-share/screem/splash/1.png
-share/screem/splash/2.png
-share/screem/splash/3.png
-share/screem/splash/4.png
-@dirrm share/screem/glade
-@dirrm share/screem/plugins
-@dirrm share/screem/resources/Applets
-@dirrm share/screem/resources/Images
-@dirrm share/screem/resources/Javascript
+share/screem/syntax/html.screem.syntax
+share/screem/syntax/perl.screem.syntax
+share/screem/syntax/php3_functions
+share/screem/syntax/screemsyntax.screem.syntax
+@dirrm share/screem/syntax
@dirrm share/screem/resources/PHP3
+@dirrm share/screem/resources/Javascript
+@dirrm share/screem/resources/Images
+@dirrm share/screem/resources/HTML
+@dirrm share/screem/resources/Applets
@dirrm share/screem/resources
-@dirrm share/screem/splash
+@dirrm share/screem/plugins
+@dirrm share/screem/htmlhelp/tables
+@dirrm share/screem/htmlhelp/special
+@dirrm share/screem/htmlhelp/phrase
+@dirrm share/screem/htmlhelp/lists
+@dirrm share/screem/htmlhelp/html
+@dirrm share/screem/htmlhelp/head
+@dirrm share/screem/htmlhelp/frames
+@dirrm share/screem/htmlhelp/forms
+@dirrm share/screem/htmlhelp/fontstyle
+@dirrm share/screem/htmlhelp/entities
+@dirrm share/screem/htmlhelp/block
+@dirrm share/screem/htmlhelp
+@dirrm share/screem/hints
+@dirrm share/screem/glade
+@dirrm share/screem/frames
@dirrm share/screem
+@dirrm share/gnome/pixmaps/screem/splash
+@dirrm share/gnome/pixmaps/screem