aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey/files/patch-bug779847
diff options
context:
space:
mode:
Diffstat (limited to 'www/seamonkey/files/patch-bug779847')
-rw-r--r--www/seamonkey/files/patch-bug77984728
1 files changed, 28 insertions, 0 deletions
diff --git a/www/seamonkey/files/patch-bug779847 b/www/seamonkey/files/patch-bug779847
new file mode 100644
index 000000000000..ed30d515af31
--- /dev/null
+++ b/www/seamonkey/files/patch-bug779847
@@ -0,0 +1,28 @@
+--- mozilla/gfx/ycbcr/Makefile.in
++++ mozilla/gfx/ycbcr/Makefile.in
+@@ -54,23 +54,13 @@ CPPSRCS += yuv_row_win.cpp \
+ $(NULL)
+ endif
+ else
+-ifeq ($(OS_ARCH),Linux)
+-CPPSRCS += yuv_row_posix.cpp \
+- $(NULL)
+-else
+-ifeq ($(OS_ARCH),SunOS)
+-CPPSRCS += yuv_row_posix.cpp \
+- $(NULL)
+-else
+-ifeq ($(OS_ARCH),Darwin)
++ifneq (,$(filter Linux SunOS Darwin DragonFly FreeBSD NetBSD OpenBSD, $(OS_ARCH)))
+ CPPSRCS += yuv_row_posix.cpp \
+ $(NULL)
+ else
+ CPPSRCS += yuv_row_other.cpp \
+ $(NULL)
+-endif # Darwin
+-endif # SunOS
+-endif # linux
++endif # posix
+ endif # windows
+
+ ifeq (arm,$(findstring arm,$(OS_TEST)))