aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2
diff options
context:
space:
mode:
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile270
-rw-r--r--www/seamonkey2/distinfo2
-rw-r--r--www/seamonkey2/files/mozilla.sh27
-rw-r--r--www/seamonkey2/files/patch-Makefile.in22
-rw-r--r--www/seamonkey2/files/patch-build_unix_run-mozilla.sh30
-rw-r--r--www/seamonkey2/files/patch-config_autoconf.mk.in18
-rw-r--r--www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp55
-rw-r--r--www/seamonkey2/files/patch-modules::libpref::src::unix::unix.js14
-rw-r--r--www/seamonkey2/files/patch-nsprpub::pr::src::pthreads::ptio.c22
-rw-r--r--www/seamonkey2/files/patch-nsprpub_pr_src_misc_prtime.c11
-rw-r--r--www/seamonkey2/files/patch-other-licenses_libical_src_libical_Makefile.in11
-rw-r--r--www/seamonkey2/files/patch-qt14
-rw-r--r--www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk25
-rw-r--r--www/seamonkey2/pkg-descr9
-rw-r--r--www/seamonkey2/pkg-descr.gtk212
-rw-r--r--www/seamonkey2/pkg-message9
16 files changed, 0 insertions, 551 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
deleted file mode 100644
index 8aa0e4fa8b79..000000000000
--- a/www/seamonkey2/Makefile
+++ /dev/null
@@ -1,270 +0,0 @@
-# New ports collection makefile for: mozilla
-# Date created: 31 Mar 1998
-# Whom: eivind/dima/jseger
-#
-# $FreeBSD$
-#
-
-PORTNAME?= mozilla
-PORTVERSION= 1.4b
-PORTREVISION?= 0
-PORTEPOCH?= 1
-CATEGORIES?= www
-MASTER_SITES= ${MASTER_SITE_MOZILLA} \
- ${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.rc/rc/}/src \
- marcus/:local
-DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.rc/rc/}${EXTRACT_SUFX} \
- libart_lgpl${EXTRACT_SUFX}:local
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= The open source, standards compliant web browser
-
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- freetype-config:${PORTSDIR}/print/freetype2
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-MOZILLA?= mozilla-devel
-MOZ_SUFX= -devel
-
-.if defined(WITH_GTK2)
-PKGNAMESUFFIX= -gtk2
-USE_GNOME= gtk20 libidl
-.else
-USE_GNOME= gtk12 orbit
-.endif
-
-.if !defined(WITHOUT_XFT)
-LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/Xft
-.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package.
-.endif
-.endif
-
-.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
- defined(WITHOUT_COMPOSER))
-BROKEN= "Calendar requires Composer and Mailnews support."
-.endif
-
-.if defined(WITH_CALENDAR)
-LIB_DEPENDS+= ical.0:${PORTSDIR}/devel/libical
-.endif
-
-LATEST_LINK= ${MOZILLA}
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
- --exclude */macbuild/*\
- --exclude */package/* \
- --exclude .cvsignore \
- --exclude makefile.win \
- --exclude MANIFEST
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_PERL5= yes
-USE_GMAKE= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= \
- --disable-auto-deps \
- --enable-chrome-format=jar \
- --disable-cpp-exceptions \
- --disable-cpp-rtti \
- --enable-crypto \
- --disable-debug \
- --disable-debug \
- --disable-gtktest \
- --disable-freetypetest \
- --disable-installer \
- --disable-glibtest \
- --enable-double-buffer \
- --enable-mathml \
- --disable-md \
- --disable-pedantic \
- --disable-bidi \
- --disable-plaintext-editor-only \
- --enable-strip \
- --enable-svg \
- --disable-tests \
- --disable-xterm-updates \
- --enable-xinerama \
- --with-system-zlib \
- --with-system-jpeg=${LOCALBASE} \
- --with-system-mng=${LOCALBASE} \
- --with-system-png=${LOCALBASE} \
- --with-pthreads
-
-PLIST= ${WRKDIR}/pkg-plist
-# LDAP is only used by mail and news so disable both together
-.if defined(WITHOUT_MAILNEWS)
-CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
-.else
-# mail and news desired, but not LDAP
-.if defined(WITHOUT_LDAP)
-CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
-.else
-CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
-.endif
-.endif
-
-.if !defined(WITHOUT_CHATZILLA)
-CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
-.else
-CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
-.endif
-CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
-
-.if defined(WITH_JAVASCRIPT_DEBUGGER)
-CONFIGURE_ARGS+= --enable-jsd \
- --enable-dtd-debug
-.else
-CONFIGURE_ARGS+= --disable-jsd \
- --disable-dtd-debug
-.endif
-
-.if defined(WITH_CALENDAR)
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --enable-calendar
-.endif
-
-.if defined(WITHOUT_COMPOSER)
-CONFIGURE_ARGS+= --disable-composer
-.endif
-
-.if defined(WITH_GTK2)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-PKGCONFIG_FILES= mozilla-gtkmozembed mozilla-js mozilla-xpcom \
- mozilla-nspr mozilla-nss mozilla-plugin
-.else
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk
-.endif
-
-.if !defined(WITHOUT_XFT)
-CONFIGURE_ARGS+= --enable-xft
-.else
-CONFIGURE_ARGS+= --disable-xft
-.endif
-
-.include <bsd.port.pre.mk>
-
-MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
- MOZ_INTERNAL_LIBART_LGPL=1
-ALL_TARGET= default
-
-.if ${ARCH} == "i386"
-CONFIGURE_ARGS+= --enable-reorder
-.endif
-
-.if defined(WITH_OPTIMIZED_CFLAGS) && ${ARCH} != "alpha"
-CFLAGS+= -O2
-CONFIGURE_ARGS+= --enable-optimize=-O2
-.endif
-
-.if ${ARCH} == "alpha"
-CFLAGS+= -O0
-CONFIGURE_ARGS+= --disable-optimize
-BROKEN= "core dumps on alpha during post-build"
-.endif
-
-.if exists(${LOCALBASE}/include/freetype/freetype.h)
-BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
-.endif
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Mozilla has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_XFT=yes Disables Xft anti-aliasing support"
- @${ECHO_MSG} " WITH_CALENDAR=yes Enables the Calendar module (requires Mailnews and Composer modules)"
- @${ECHO_MSG} " WITHOUT_MAILNEWS=yes Disables the Mail and News modules"
- @${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
- @${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
- @${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
- @${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
- @${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
- @${ECHO_MSG} ""
-.if defined(WITH_CALENDAR)
- @${ECHO_MSG} "Calendar is still beta software."
- @${ECHO_MSG} "Use at your own risk."
- @${ECHO_MSG} "http://mozilla.org/projects/calendar/"
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/build/unix/run-mozilla.sh
- @${REINPLACE_CMD} -e 's|%%MOZILLA%%|${MOZILLA}|g' \
- -e 's|%%HEADERS_SUFX%%|${MOZ_SUFX}|g' \
- ${WRKSRC}/config/autoconf.mk.in
- @${FIND} ${WRKSRC}/other-licenses/libical -name "*.c" | ${XARGS} \
- ${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g'
-.if defined(WITH_GTK2)
- @for pcfile in ${PKGCONFIG_FILES}; do \
- ${REINPLACE_CMD} -e 's|mozilla-xpcom|mozilla-xpcom${MOZ_SUFX}|g ; \
- s|mozilla-nspr|mozilla-nspr${MOZ_SUFX}|g' \
- ${WRKSRC}/build/unix/$${pcfile}.pc.in; \
- done
-.endif
-
-post-build:
- ${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
- ${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
- (cd ${WRKSRC}/dist/bin; \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome; \
- ${TOUCH} ./chrome/user-skins.rdf ./chrome/user-locales.rdf)
- ${FIND} ${WRKSRC}/dist/bin -type d | /usr/bin/sort -r | \
- ${XARGS} ${RMDIR} 2> /dev/null || ${TRUE}
-
-pre-install:
- ${RM} -f ${PLIST}
- ${TOUCH} -f ${PLIST}
- if [ ! -x ${PREFIX}/bin/mozilla -a ! -L ${PREFIX}/bin/mozilla ]; then \
- ${ECHO_CMD} bin/mozilla >> ${PLIST} ; \
- fi
- ${ECHO_CMD} bin/${MOZILLA} >> ${PLIST}
- if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
- ${ECHO_CMD} lib/browser_plugins/libjavaplugin_oji.so >> ${PLIST} ; \
- ${ECHO_CMD} @dirrm lib/browser_plugins >> ${PLIST} ; \
- fi
- cd ${WRKSRC}/dist/bin && ${FIND} -s * -type f -o -type l | \
- ${SED} -e 's:^:lib/${MOZILLA}/:' >> ${PLIST} \
- && ${FIND} -d * -type d | \
- ${SED} -e 's:^:@dirrm lib/${MOZILLA}/:' >> ${PLIST}
- ${ECHO_CMD} @dirrm lib/${MOZILLA} >> ${PLIST}
-.if defined(WITH_GTK2)
- for pcfile in ${PKGCONFIG_FILES}; do \
- ${ECHO_CMD} libdata/pkgconfig/$${pcfile}${MOZ_SUFX}.pc >> ${PLIST} ; \
- done
-.endif
-
-do-install:
- ${MKDIR} ${PREFIX}/lib/${MOZILLA}
- ${CHMOD} 755 ${PREFIX}/lib/${MOZILLA}
- cd ${WRKSRC}/dist/bin && ${FIND} . | \
- cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/${MOZILLA}
- ${INSTALL_SCRIPT} ${WRKSRC}/${MOZILLA} ${PREFIX}/bin
- if [ ! -x ${PREFIX}/bin/mozilla -a ! -L ${PREFIX}/bin/mozilla ]; then \
- ${LN} -sf ${PREFIX}/bin/${MOZILLA} ${PREFIX}/bin/mozilla ; \
- fi
- if [ ! -d ${PREFIX}/lib/browser_plugins ]; then \
- ${MKDIR} ${PREFIX}/lib/browser_plugins ; \
- fi
- if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
- ${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
- ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ; \
- fi
-.if defined(WITH_GTK2)
- for pcfile in ${PKGCONFIG_FILES}; do \
- ${INSTALL_DATA} ${WRKSRC}/build/unix/$${pcfile}.pc \
- ${PREFIX}/libdata/pkgconfig/$${pcfile}${MOZ_SUFX}.pc ; \
- done
-.endif
-
-post-install:
- @${CHMOD} -R u-w ${PREFIX}/lib/${MOZILLA}/components
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/www/seamonkey2/distinfo b/www/seamonkey2/distinfo
deleted file mode 100644
index 5c3c1602b908..000000000000
--- a/www/seamonkey2/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (mozilla-source-1.4b.tar.bz2) = 63c591ea36ed3864a1ccd4cc4f59d009
-MD5 (libart_lgpl.tar.bz2) = f332c3c026adc1c2c0ceb3ac5847d5f5
diff --git a/www/seamonkey2/files/mozilla.sh b/www/seamonkey2/files/mozilla.sh
deleted file mode 100644
index bbc7d2568bc6..000000000000
--- a/www/seamonkey2/files/mozilla.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-
-MOZILLA_DIR="%%PREFIX%%/lib/%%MOZILLA%%"
-MOZILLA_EXEC="mozilla"
-LOCATION='new-tab'
-
-cd $MOZILLA_DIR || exit 1
-
-case $1 in
- -mail)
- REMOTE_COMMAND="xfeDoCommand (openInbox)"
- ;;
- -*)
- exec ./$MOZILLA_EXEC "$@"
- ;;
- *)
- REMOTE_COMMAND="openURL($@, $LOCATION)"
- ;;
-esac
-
-# process found
-./$MOZILLA_EXEC -remote "ping()" &&
-./$MOZILLA_EXEC -remote "$REMOTE_COMMAND" && exit 0
-
-# no existing process
-exec ./$MOZILLA_EXEC "$@"
-
diff --git a/www/seamonkey2/files/patch-Makefile.in b/www/seamonkey2/files/patch-Makefile.in
deleted file mode 100644
index 43fa34684782..000000000000
--- a/www/seamonkey2/files/patch-Makefile.in
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.in.orig Thu May 30 20:39:07 2002
-+++ Makefile.in Wed Aug 28 13:55:32 2002
-@@ -70,8 +70,7 @@
- $(tier_0_dirs) \
- $(tier_1_dirs) \
- $(tier_2_dirs) \
-- $(tier_9_dirs) \
-- $(NULL)
-+ $(tier_9_dirs)
-
- ifdef GC_LEAK_DETECTOR
- DIRS += gc/boehm
-@@ -90,7 +89,8 @@
- DIRS += $(tier_98_dirs)
- endif
-
--DIRS += $(tier_99_dirs)
-+DIRS += $(tier_99_dirs) \
-+ $(NULL)
-
- #
- # tier 0 - base build config dirs
diff --git a/www/seamonkey2/files/patch-build_unix_run-mozilla.sh b/www/seamonkey2/files/patch-build_unix_run-mozilla.sh
deleted file mode 100644
index 96084fd68646..000000000000
--- a/www/seamonkey2/files/patch-build_unix_run-mozilla.sh
+++ /dev/null
@@ -1,30 +0,0 @@
---- build/unix/run-mozilla.sh.orig Wed Oct 23 00:08:03 2002
-+++ build/unix/run-mozilla.sh Wed Oct 23 00:08:59 2002
-@@ -355,7 +355,7 @@
- fi
- ##
- ## Set LD_LIBRARY_PATH
--LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
-+LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:%%PREFIX%%/lib/browser_plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
- if [ -n "$LD_LIBRARYN32_PATH" ]
- then
- LD_LIBRARYN32_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARYN32_PATH+":$LD_LIBRARYN32_PATH"}
-@@ -392,7 +392,7 @@
- export XSUNTRANSPORT XSUNSMESIZE
- fi
- # Font path for Xft
--FONTCONFIG_PATH="/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
-+FONTCONFIG_PATH="%%PREFIX%%/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
- export FONTCONFIG_PATH
-
- if [ "$moz_debug" -eq 1 ]
-@@ -435,6 +435,9 @@
- #
- export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
- export SHLIB_PATH LIBPATH LIBRARY_PATH ADDON_PATH DYLD_LIBRARY_PATH
-+
-+MOZ_PLUGIN_PATH=%%PREFIX%%/lib/browser_plugins
-+export MOZ_PLUGIN_PATH
-
- if [ $moz_debug -eq 1 ]
- then
diff --git a/www/seamonkey2/files/patch-config_autoconf.mk.in b/www/seamonkey2/files/patch-config_autoconf.mk.in
deleted file mode 100644
index c119b0c2c6a8..000000000000
--- a/www/seamonkey2/files/patch-config_autoconf.mk.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- config/autoconf.mk.in.orig Sun Nov 17 14:47:49 2002
-+++ config/autoconf.mk.in Sun Nov 17 14:48:17 2002
-@@ -30,13 +30,13 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- bindir = @bindir@
--includedir = @includedir@/mozilla-$(MOZILLA_VERSION)
-+includedir = @includedir@/mozilla%%HEADERS_SUFX%%
- libdir = @libdir@
- datadir = @datadir@
- mandir = @mandir@
- idldir = @datadir@/idl/mozilla-$(MOZILLA_VERSION)
-
--mozappdir = $(libdir)/mozilla-$(MOZILLA_VERSION)
-+mozappdir = $(libdir)/%%MOZILLA%%
- mredir = $(libdir)/mre/mre-$(MOZILLA_VERSION)
- mrelibdir = $(mredir)/lib
-
diff --git a/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp b/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
deleted file mode 100644
index 0071f169c0e2..000000000000
--- a/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
+++ /dev/null
@@ -1,55 +0,0 @@
---- gfx/src/gtk/nsFontMetricsXft.cpp.orig Tue Mar 25 16:13:01 2003
-+++ gfx/src/gtk/nsFontMetricsXft.cpp Mon Apr 14 10:21:18 2003
-@@ -90,6 +90,7 @@
- FcPattern *mPattern;
- FcPattern *mFontName;
- FcCharSet *mCharset;
-+ int mNotXft;
- };
-
- struct MozXftLangGroup {
-@@ -772,7 +773,7 @@
- // font in our loaded list that supports the character
- for (PRInt32 i = 0, end = mLoadedFonts.Count(); i < end; ++i) {
- nsFontXft *font = (nsFontXft *)mLoadedFonts.ElementAt(i);
-- if (FcCharSetHasChar(font->mCharset, aChar))
-+ if (FcCharSetHasChar(font->mCharset, aChar) && font->GetXftFont())
- return font;
- }
-
-@@ -1194,7 +1195,7 @@
- for (PRInt32 j = 0, end = mLoadedFonts.Count(); j < end; ++j) {
- nsFontXft *font;
- font = (nsFontXft *)mLoadedFonts.ElementAt(j);
-- if (FcCharSetHasChar(font->mCharset, c)) {
-+ if (FcCharSetHasChar(font->mCharset, c) && font->GetXftFont()) {
- foundFont = font;
- break;
- }
-@@ -1503,6 +1504,7 @@
- FcPatternReference(mFontName);
-
- mXftFont = nsnull;
-+ mNotXft = 0;
-
- // set up our charset
- mCharset = nsnull;
-@@ -1529,14 +1531,16 @@
- XftFont *
- nsFontXft::GetXftFont(void)
- {
-- if (!mXftFont) {
-+ if (!mXftFont && !mNotXft) {
- FcPattern *pat = FcFontRenderPrepare(0, mPattern, mFontName);
- if (!pat)
- return nsnull;
-
- mXftFont = XftFontOpenPattern(GDK_DISPLAY(), pat);
-- if (!mXftFont)
-+ if (!mXftFont) {
- FcPatternDestroy(pat);
-+ mNotXft = 1;
-+ }
- }
-
- return mXftFont;
diff --git a/www/seamonkey2/files/patch-modules::libpref::src::unix::unix.js b/www/seamonkey2/files/patch-modules::libpref::src::unix::unix.js
deleted file mode 100644
index bd39a70bf05d..000000000000
--- a/www/seamonkey2/files/patch-modules::libpref::src::unix::unix.js
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- modules/libpref/src/unix/unix.js 2002/03/14 15:04:20 1.1
-+++ modules/libpref/src/unix/unix.js 2002/03/14 15:04:38
-@@ -227,7 +227,7 @@
-
- // TrueType
- pref("font.FreeType2.enable", false);
--pref("font.freetype2.shared-library", "libfreetype.so.6");
-+pref("font.freetype2.shared-library", "libfreetype.so.9");
- // if libfreetype was built without hinting compiled in
- // it is best to leave hinting off
- pref("font.FreeType2.autohinted", false);
diff --git a/www/seamonkey2/files/patch-nsprpub::pr::src::pthreads::ptio.c b/www/seamonkey2/files/patch-nsprpub::pr::src::pthreads::ptio.c
deleted file mode 100644
index 4a965d4c7440..000000000000
--- a/www/seamonkey2/files/patch-nsprpub::pr::src::pthreads::ptio.c
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: nsprpub/pr/src/pthreads/ptio.c
-diff -u nsprpub/pr/src/pthreads/ptio.c.orig nsprpub/pr/src/pthreads/ptio.c
---- nsprpub/pr/src/pthreads/ptio.c.orig Fri Apr 12 03:14:39 2002
-+++ nsprpub/pr/src/pthreads/ptio.c Tue Jul 30 18:52:11 2002
-@@ -3414,6 +3414,17 @@
- if (osfd == -1) pt_MapError(_PR_MD_MAP_SOCKET_ERROR, errno);
- else
- {
-+#if (defined(_PR_INET6_PROBE) || defined(_PR_INET6)) && \
-+ defined(__FreeBSD__) && defined(IPV6_V6ONLY)
-+ if (domain == PR_AF_INET6) {
-+ int opt = 0;
-+ if (setsockopt(osfd, IPPROTO_IPV6, IPV6_V6ONLY,
-+ &opt, sizeof(opt))) {
-+ close(osfd);
-+ return NULL;
-+ }
-+ }
-+#endif
- fd = pt_SetMethods(osfd, ftype, PR_FALSE, PR_FALSE);
- if (fd == NULL) close(osfd);
- }
diff --git a/www/seamonkey2/files/patch-nsprpub_pr_src_misc_prtime.c b/www/seamonkey2/files/patch-nsprpub_pr_src_misc_prtime.c
deleted file mode 100644
index 30f067cfaf56..000000000000
--- a/www/seamonkey2/files/patch-nsprpub_pr_src_misc_prtime.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- nsprpub/pr/src/misc/prtime.c.orig Wed Feb 26 19:01:02 2003
-+++ nsprpub/pr/src/misc/prtime.c Sun Apr 6 19:22:10 2003
-@@ -1666,7 +1666,7 @@
- */
-
- #if defined(SUNOS4) || (__GLIBC__ >= 2) || defined(XP_BEOS) \
-- || defined(NETBSD)
-+ || defined(NETBSD) || defined(__FreeBSD__)
- a.tm_zone = NULL;
- a.tm_gmtoff = tm->tm_params.tp_gmt_offset + tm->tm_params.tp_dst_offset;
- #endif
diff --git a/www/seamonkey2/files/patch-other-licenses_libical_src_libical_Makefile.in b/www/seamonkey2/files/patch-other-licenses_libical_src_libical_Makefile.in
deleted file mode 100644
index f7b62d4df6a2..000000000000
--- a/www/seamonkey2/files/patch-other-licenses_libical_src_libical_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- other-licenses/libical/src/libical/Makefile.in.orig Thu Feb 13 15:50:58 2003
-+++ other-licenses/libical/src/libical/Makefile.in Thu Feb 13 15:51:07 2003
-@@ -179,7 +179,7 @@
- $(PERL) $(ICALSCRIPTS)/mkrestrictiontable.pl -i $(srcdir)/icalrestriction.c.in \
- $(DESIGNDATA)/restrictions.csv > icalrestriction.c
-
--ifneq (,$(filter BeOS Darwin OpenVMS,$(OS_ARCH)))
-+ifneq (,$(filter BeOS Darwin OpenVMS FreeBSD,$(OS_ARCH)))
- DEFINES += -D__USE_BSD=1
- endif
-
diff --git a/www/seamonkey2/files/patch-qt b/www/seamonkey2/files/patch-qt
deleted file mode 100644
index 27f44eaa4cdb..000000000000
--- a/www/seamonkey2/files/patch-qt
+++ /dev/null
@@ -1,14 +0,0 @@
---- configure.orig Sat May 3 16:18:13 2003
-+++ configure Fri May 16 15:22:46 2003
-@@ -11851,9 +11851,9 @@
-
-
-
--MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector irc universalchardet typeaheadfind webservices"
-+MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector universalchardet typeaheadfind webservices"
-
--MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm access-builtin datetime finger cview"
-+MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm access-builtin datetime finger cview"
-
- # Check whether --enable-extensions or --disable-extensions was given.
- if test "${enable_extensions+set}" = set; then
diff --git a/www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk b/www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk
deleted file mode 100644
index 783d452b2896..000000000000
--- a/www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk
+++ /dev/null
@@ -1,25 +0,0 @@
-
-$FreeBSD$
-
---- security/coreconf/FreeBSD.mk.orig Sat Mar 9 00:17:36 2002
-+++ security/coreconf/FreeBSD.mk Tue Mar 12 17:19:15 2002
-@@ -35,9 +35,7 @@
-
- include $(CORE_DEPTH)/coreconf/UNIX.mk
-
--DEFAULT_COMPILER = gcc
--CC = gcc
--CCC = g++
-+CCC = ${CXX}
- RANLIB = ranlib
-
- ifeq ($(OS_TEST),alpha)
-@@ -70,7 +68,7 @@
- DLL_SUFFIX = so.1.0
- endif
-
--MKSHLIB = $(CC) $(DSO_LDOPTS)
-+MKSHLIB = $(CC) $(DSO_LDOPTS) -o $@
- ifdef MAPFILE
- # Add LD options to restrict exported symbols to those in the map file
- endif
diff --git a/www/seamonkey2/pkg-descr b/www/seamonkey2/pkg-descr
deleted file mode 100644
index fe21e2f4102c..000000000000
--- a/www/seamonkey2/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-This is the current release of the Mozilla open source web browser. It should
-be fully compliant with all W3C standards, including HTML, CSS, XML, XSL,
-JavaScript, MathML, SVG and RDF. This version also supports SSL encryption,
-and Java with the use of the FreeBSD native Java plug-in.
-
-This is the latest bleeding edge release. Beware that you'll probably find
-bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
-
-WWW: http://www.mozilla.org/
diff --git a/www/seamonkey2/pkg-descr.gtk2 b/www/seamonkey2/pkg-descr.gtk2
deleted file mode 100644
index 10b9ea56ea93..000000000000
--- a/www/seamonkey2/pkg-descr.gtk2
+++ /dev/null
@@ -1,12 +0,0 @@
-This is the current release of the Mozilla open source web browser. It should
-be fully compliant with all W3C standards, including HTML, CSS, XML, XSL,
-JavaScript, MathML, SVG and RDF. This version also supports SSL encryption,
-and Java with the use of the FreeBSD native Java plug-in.
-
-This is the latest bleeding edge release. Beware that you'll probably find
-bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
-
-This version has been built with GTK+-2 bindings for use with applications
-such as Galeon 2.
-
-WWW: http://www.mozilla.org/
diff --git a/www/seamonkey2/pkg-message b/www/seamonkey2/pkg-message
deleted file mode 100644
index a98a376da558..000000000000
--- a/www/seamonkey2/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
-###
-A symlink has been created for the Java plugin. However, in order for Java
-to function, you must first install the java/jdk13 port. If you do not
-do this, you will see the following error when starting Mozilla:
-
-LoadPlugin: failed to initialize shared library /usr/local/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so [Cannot open "/usr/local/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so"]
-
-If you do not want Java support, you can safely ignore this message.
-###