aboutsummaryrefslogtreecommitdiff
path: root/www/squid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/squid/Makefile')
-rw-r--r--www/squid/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 6151e7e8bb6a..08f5725df41e 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -73,7 +73,7 @@
PORTNAME= squid
PORTVERSION= 2.5.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -132,7 +132,7 @@ OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
SQUID_STACKTRACES "Create backtraces on fatal errors" off \
SQUID_RCNG "Install an rcNG startup script" on
-etc_files= rc.d/squid${rc_suffix} squid/cachemgr.conf.default \
+etc_files= rc.d/squid.sh squid/cachemgr.conf.default \
squid/mib.txt squid/mime.conf.default \
squid/msntauth.conf.default squid/squid.conf.default
@@ -317,11 +317,9 @@ STRIP= ""
USE_RC_SUBR= yes
rc_del= rcold
rc_state= rcng
-rc_suffix=
.else
rc_del= rcng
rc_state= rcold
-rc_suffix= .sh
.endif
# Languages:
@@ -388,7 +386,7 @@ post-install:
${CHMOD} 4510 ${PREFIX}/libexec/squid/pinger; \
${CHGRP} ${SQUID_GID} ${PREFIX}/libexec/squid/pinger
.endif
- ${INSTALL_SCRIPT} ${WRKDIR}/squid.sh ${PREFIX}/etc/rc.d/squid${rc_suffix}
+ ${INSTALL_SCRIPT} ${WRKDIR}/squid.sh ${PREFIX}/etc/rc.d/
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${docs} ${DOCSDIR}