aboutsummaryrefslogtreecommitdiff
path: root/www/tomcat41/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/tomcat41/Makefile')
-rw-r--r--www/tomcat41/Makefile56
1 files changed, 27 insertions, 29 deletions
diff --git a/www/tomcat41/Makefile b/www/tomcat41/Makefile
index 2fe0c1d7944e..2a8597c4167c 100644
--- a/www/tomcat41/Makefile
+++ b/www/tomcat41/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 3.2.4
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= http://jakarta.apache.org/builds/jakarta-tomcat/release/v${PORTVERSION}/bin/ \
http://www.metaverse.nl/~ernst/ \
@@ -25,40 +26,34 @@ LOG_DIR= ${APP_HOME}/logs
PLIST_SUB+= T=${APP_HOME:S/^${PREFIX}\///}
APP_TITLE= Jakarta Tomcat
APP_SHORTNAME= tomcat
-APPCTL_NAME= ${APP_SHORTNAME}ctl
-CTL_SCRIPT= ${PREFIX}/bin/${APPCTL_NAME}
+CONTROL_SCRIPT_NAME= ${APP_SHORTNAME}ctl
+CONTROL_SCRIPT= ${PREFIX}/bin/${CONTROL_SCRIPT_NAME}
STARTUP_ORDER?= 020
STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${STARTUP_ORDER}.${PORTNAME}.sh
JAVA_HOME?= ${LOCALBASE}/jdk1.3.1
JAVA_PORT?= ${PORTSDIR}/java/jdk13
-USER_NAME?= ${APP_SHORTNAME}
-GROUP_NAME?= ${USER_NAME}
-USER_ID?= 7103
-GROUP_ID?= ${USER_ID}
+USER_NAME= www
+GROUP_NAME= www
PW?= /usr/sbin/pw
LISTEN_PORT?= 8080
-STDOUT_LOG?= ${LOG_DIR}/stdout.log
-STDERR_LOG?= ${LOG_DIR}/stderr.log
+STDOUT_LOG= ${LOG_DIR}/stdout.log
+STDERR_LOG= ${LOG_DIR}/stderr.log
AUTO_START?= NO
pre-install:
@${ECHO_CMD} "Installation settings:"
@${ECHO_CMD} " Destination directory: ${APP_HOME}"
- @${ECHO_CMD} " Control script location: ${CTL_SCRIPT}"
+ @${ECHO_CMD} " Control script location: ${CONTROL_SCRIPT}"
@${ECHO_CMD} " Startup script location: ${STARTUP_SCRIPT}"
@${ECHO_CMD} " Location of JDK: ${JAVA_HOME}"
@${ECHO_CMD} " Location of Java port: ${JAVA_PORT}"
- @${ECHO_CMD} " Running as (user/group): ${USER_NAME}/${GROUP_NAME} (${USER_ID}:${GROUP_ID})"
+ @${ECHO_CMD} " Running as (user/group): ${USER_NAME}/${GROUP_NAME}"
@${ECHO_CMD} " Port to listen at: ${LISTEN_PORT}"
@${ECHO_CMD} " Logfile stdout: ${STDOUT_LOG}"
@${ECHO_CMD} " Logfile stderr: ${STDERR_LOG}"
@${ECHO_CMD} " Starting after install: ${AUTO_START}"
do-install:
- @# Add the group and the user if they do not exist
- ${PW} groupadd -n ${GROUP_NAME} -g ${GROUP_ID} || true
- ${PW} useradd -n ${USER_NAME} -u ${USER_ID} -g ${GROUP_NAME} -c "${APP_TITLE} account" -d ${APP_HOME} -s ${SH} -h - || true
-
@# Create the destination directory
${MKDIR} ${APP_HOME}
@@ -75,10 +70,17 @@ do-install:
> ${WRKDIR}/workers.properties
${MV} ${WRKDIR}/workers.properties ${APP_HOME}/conf/workers.properties
+ @# Install the startup script
+ ${CAT} ${FILESDIR}/${PORTNAME}.sh \
+ | ${SED} "/%%USER_NAME%%/s//${USER_NAME}/" \
+ | ${SED} "/%%APP_SHORTNAME%%/s//${APP_SHORTNAME}/" \
+ | ${SED} "/%%CONTROL_SCRIPT%%/s//${CONTROL_SCRIPT:S/\//\\\//g}/" \
+ > ${STARTUP_SCRIPT}
+ ${CHMOD} 0554 ${STARTUP_SCRIPT}
+
@# Install the control script
- ${CAT} ${FILESDIR}/${APPCTL_NAME} \
+ ${CAT} ${FILESDIR}/${CONTROL_SCRIPT_NAME} \
| ${SED} "/%%PORTNAME%%/s//${PORTNAME}/" \
- | ${SED} "/%%PORTVERSION%%/s//${PORTVERSION}/" \
| ${SED} "/%%APP_TITLE%%/s//${APP_TITLE}/" \
| ${SED} "/%%APP_SHORTNAME%%/s//${APP_SHORTNAME}/" \
| ${SED} "/%%APP_HOME%%/s//${APP_HOME:S/\//\\\//g}/" \
@@ -88,13 +90,9 @@ do-install:
| ${SED} "/%%USER_NAME%%/s//${USER_NAME}/" \
| ${SED} "/%%STDOUT_LOG%%/s//${STDOUT_LOG:S/\//\\\//g}/" \
| ${SED} "/%%STDERR_LOG%%/s//${STDERR_LOG:S/\//\\\//g}/" \
- > ${CTL_SCRIPT}
- ${CHOWN} ${USER_NAME}:${GROUP_NAME} ${CTL_SCRIPT}
- ${CHMOD} 6554 ${CTL_SCRIPT}
-
- @# Install the startup script
- ${CP} ${FILESDIR}/${PORTNAME}.sh ${STARTUP_SCRIPT}
- ${CHMOD} 0554 ${STARTUP_SCRIPT}
+ > ${CONTROL_SCRIPT}
+ ${CHOWN} ${USER_NAME}:${GROUP_NAME} ${CONTROL_SCRIPT}
+ ${CHMOD} 6554 ${CONTROL_SCRIPT}
@# Create the directories that the application will create at the
@# first run
@@ -115,21 +113,21 @@ do-install:
@# Install the man page
.if !defined(NOPORTDOCS)
- ${CAT} ${FILESDIR}/${APPCTL_NAME}.1 \
+ ${CAT} ${FILESDIR}/${CONTROL_SCRIPT_NAME}.1 \
| ${SED} "/%%PREFIX%%/s//${PREFIX:S/\//\\\//g}/" \
- > ${WRKDIR}/${APPCTL_NAME}.1
- ${INSTALL_MAN} ${WRKDIR}/${APPCTL_NAME}.1 ${MANPREFIX}/man/man1
+ > ${WRKDIR}/${CONTROL_SCRIPT_NAME}.1
+ ${INSTALL_MAN} ${WRKDIR}/${CONTROL_SCRIPT_NAME}.1 ${MANPREFIX}/man/man1
.endif
post-install:
@${ECHO_CMD} "${APP_TITLE} ${PORTVERSION} has been installed in ${APP_HOME}."
- @${ECHO_CMD} "If you would like a user to be able to use ${APPCTL_NAME}, then put this user in the group ${GROUP_NAME}."
+ @${ECHO_CMD} "If you would like a user to be able to use ${CONTROL_SCRIPT_NAME}, then put this user in the group ${GROUP_NAME}."
.if !defined(NOPORTDOCS)
- @${ECHO_CMD} "Use 'man ${APPCTL_NAME}' for information about starting and stopping ${APP_TITLE}."
+ @${ECHO_CMD} "Use 'man ${CONTROL_SCRIPT_NAME}' for information about starting and stopping ${APP_TITLE}."
.endif
.if ${AUTO_START} == "YES"
@${ECHO_CMD} "Starting ${APP_TITLE}..."
- @${CTL_SCRIPT} start || true
+ @${CONTROL_SCRIPT} start || true
.endif
.include <bsd.port.mk>