aboutsummaryrefslogtreecommitdiff
path: root/www/trac-ldap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/trac-ldap/Makefile')
-rw-r--r--www/trac-ldap/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/trac-ldap/Makefile b/www/trac-ldap/Makefile
new file mode 100644
index 000000000000..761c0b5f9494
--- /dev/null
+++ b/www/trac-ldap/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: trac-ldap
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldap
+PORTVERSION= 0.5.1
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= LDAP extenstions for Trac
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ ${PYTHON_SITELIBDIR}/_ldap.so:${PORTSDIR}/net/py-ldap2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION}dev PYTHONVERSION=${_PYTHON_VERSION}
+
+.include <bsd.port.mk>