aboutsummaryrefslogtreecommitdiff
path: root/www/twhttpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/twhttpd/Makefile')
-rw-r--r--www/twhttpd/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/twhttpd/Makefile b/www/twhttpd/Makefile
index aedb8f8d16b5..a5e73fff10e1 100644
--- a/www/twhttpd/Makefile
+++ b/www/twhttpd/Makefile
@@ -19,6 +19,12 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 213
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-install:
@${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
@${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
@@ -26,4 +32,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>