aboutsummaryrefslogtreecommitdiff
path: root/www/varnish2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/varnish2/Makefile')
-rw-r--r--www/varnish2/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/varnish2/Makefile b/www/varnish2/Makefile
index d6b5e5034dc3..11f21e41dadf 100644
--- a/www/varnish2/Makefile
+++ b/www/varnish2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= varnish
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,7 +22,7 @@ USE_LDCONFIG= yes
MAN1= varnishd.1 varnishhist.1 varnishlog.1 varnishncsa.1 \
varnishstat.1 varnishtop.1
MAN7= vcl.7
-USE_RC_SUBR+= varnishd
+USE_RC_SUBR= varnishd varnishlog
.include <bsd.port.pre.mk>
@@ -30,4 +30,9 @@ USE_RC_SUBR+= varnishd
BROKEN= does not compile
.endif
+post-install:
+ ${MKDIR} ${PREFIX}/etc/varnish
+ @[ -f ${PREFIX}/etc/varnish/default.vcl ] || \
+ ${INSTALL_DATA} ${WRKSRC}/etc/default.vcl ${PREFIX}/etc/varnish/
+
.include <bsd.port.post.mk>