aboutsummaryrefslogtreecommitdiff
path: root/www/varnish
diff options
context:
space:
mode:
Diffstat (limited to 'www/varnish')
-rw-r--r--www/varnish/Makefile9
-rw-r--r--www/varnish/distinfo6
-rw-r--r--www/varnish/files/varnishd.in19
-rw-r--r--www/varnish/files/varnishlog.in39
-rw-r--r--www/varnish/pkg-plist2
5 files changed, 67 insertions, 8 deletions
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index d6b5e5034dc3..11f21e41dadf 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= varnish
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,7 +22,7 @@ USE_LDCONFIG= yes
MAN1= varnishd.1 varnishhist.1 varnishlog.1 varnishncsa.1 \
varnishstat.1 varnishtop.1
MAN7= vcl.7
-USE_RC_SUBR+= varnishd
+USE_RC_SUBR= varnishd varnishlog
.include <bsd.port.pre.mk>
@@ -30,4 +30,9 @@ USE_RC_SUBR+= varnishd
BROKEN= does not compile
.endif
+post-install:
+ ${MKDIR} ${PREFIX}/etc/varnish
+ @[ -f ${PREFIX}/etc/varnish/default.vcl ] || \
+ ${INSTALL_DATA} ${WRKSRC}/etc/default.vcl ${PREFIX}/etc/varnish/
+
.include <bsd.port.post.mk>
diff --git a/www/varnish/distinfo b/www/varnish/distinfo
index a461de944adf..4f045547853b 100644
--- a/www/varnish/distinfo
+++ b/www/varnish/distinfo
@@ -1,3 +1,3 @@
-MD5 (varnish-1.0.3.tar.gz) = f942bfa029be8a9af9692a43bd04158c
-SHA256 (varnish-1.0.3.tar.gz) = 15c2efdb3e70b3eccc17145f5b24c315d6301e169a5008de8987ab9d437f75e5
-SIZE (varnish-1.0.3.tar.gz) = 541822
+MD5 (varnish-1.0.4.tar.gz) = 2a917e485700d44b28c0d0b626ea90d8
+SHA256 (varnish-1.0.4.tar.gz) = f9f8f121cdea87133b7923b92ea08cac90ab08ffdc325166ccea22449114b2ea
+SIZE (varnish-1.0.4.tar.gz) = 533057
diff --git a/www/varnish/files/varnishd.in b/www/varnish/files/varnishd.in
index 5d325d882d21..92054025c944 100644
--- a/www/varnish/files/varnishd.in
+++ b/www/varnish/files/varnishd.in
@@ -12,7 +12,15 @@
#
#varnishd_enable="YES"
#
-# See varnishd(1) for flags.
+# Configuration variables and their default values:
+#
+#varnishd_listen=":6081"
+#varnishd_config="%%PREFIX%%/etc/varnish/default.vcl"
+#varnishd_telnet="localhost:6082"
+#varnishd_storage="file,/tmp,50%"
+#varnishd_flags="-P ${pidfile} -a ${varnishd_listen} -f ${varnishd_config} -T ${varnishd_telnet} -s ${varnishd_storage}"
+#
+# See varnishd(1) for a detailed overview of command-line options.
#
. %%RC_SUBR%%
@@ -20,12 +28,17 @@
name=varnishd
rcvar=`set_rcvar`
-command=%%PREFIX%%/sbin/varnishd
+command="%%PREFIX%%/sbin/varnishd"
+pidfile="/var/run/${name}.pid"
# set defaults
varnishd_enable=${varnishd_enable:-"NO"}
-varnishd_flags=${varnishd_flags:-""}
+varnishd_listen=${varnishd_listen:-":6081"}
+varnishd_config=${varnishd_config:-"%%PREFIX%%/etc/varnish/default.vcl"}
+varnishd_telnet=${varnishd_telnet:-"localhost:6082"}
+varnishd_storage=${varnishd_storage:-"file,/tmp,50%"}
+varnishd_flags=${varnishd_flags:-"-P ${pidfile} -a ${varnishd_listen} -f ${varnishd_config} -T ${varnishd_telnet} -s ${varnishd_storage}"}
load_rc_config ${name}
diff --git a/www/varnish/files/varnishlog.in b/www/varnish/files/varnishlog.in
new file mode 100644
index 000000000000..38e5beb012b7
--- /dev/null
+++ b/www/varnish/files/varnishlog.in
@@ -0,0 +1,39 @@
+#!/bin/sh
+#
+# $Id$
+#
+
+# PROVIDE: varnishlog
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable varnishlog:
+#
+#varnishlog_enable="YES"
+#
+# Configuration variables and their default values:
+#
+#varnishlog_file=${varnishlog_file:-"/var/log/varnish.log"}
+#varnishlog_flags=${varnishlog_flags:-"-D -P ${pidfile} -a -w ${varnishlog_file}"}
+#
+# See varnishlog(1) for a detailed overview of command-line options.
+#
+
+. %%RC_SUBR%%
+
+name=varnishlog
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/varnishlog"
+pidfile="/var/run/${name}.pid"
+
+# set defaults
+
+varnishlog_enable=${varnishlog_enable:-"NO"}
+varnishlog_file=${varnishlog_file:-"/var/log/varnish.log"}
+varnishlog_flags=${varnishlog_flags:-"-P ${pidfile} -D -a -w ${varnishlog_file}"}
+
+load_rc_config ${name}
+
+run_rc_command "$1"
diff --git a/www/varnish/pkg-plist b/www/varnish/pkg-plist
index 448ce47966de..d15ff79b3b53 100644
--- a/www/varnish/pkg-plist
+++ b/www/varnish/pkg-plist
@@ -3,6 +3,7 @@ bin/varnishlog
bin/varnishncsa
bin/varnishstat
bin/varnishtop
+etc/varnish/default.vcl
lib/libvarnish.so.0
lib/libvarnish.so
lib/libvarnish.la
@@ -16,3 +17,4 @@ lib/libvcl.so
lib/libvcl.la
lib/libvcl.a
sbin/varnishd
+@dirrm etc/varnish