aboutsummaryrefslogtreecommitdiff
path: root/www/w3m
diff options
context:
space:
mode:
Diffstat (limited to 'www/w3m')
-rw-r--r--www/w3m/Makefile2
-rw-r--r--www/w3m/files/patch-file.c13
2 files changed, 12 insertions, 3 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index de7b82dd63a7..09e09eea95ae 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -7,7 +7,7 @@
PORTNAME= w3m
PORTVERSION= ${W3M_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES+= www ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/www/w3m/files/patch-file.c b/www/w3m/files/patch-file.c
index 07868a248356..1fbe9228c75b 100644
--- a/www/w3m/files/patch-file.c
+++ b/www/w3m/files/patch-file.c
@@ -1,5 +1,5 @@
---- file.c.orig Sun Feb 19 01:37:44 2006
-+++ file.c Sun Feb 19 01:39:59 2006
+--- file.c.orig Tue Jan 2 22:11:50 2007
++++ file.c Tue Jan 2 22:14:11 2007
@@ -262,7 +262,8 @@
{
return (type == NULL || type[0] == '\0' ||
@@ -10,6 +10,15 @@
}
static int
+@@ -7799,7 +7800,7 @@
+ ans = inputChar(prompt);
+ }
+ else {
+- printf(prompt);
++ printf("%s", prompt);
+ fflush(stdout);
+ ans = Strfgets(stdin)->ptr;
+ }
@@ -7891,7 +7892,7 @@
uf->scheme = SCM_LOCAL;
}