aboutsummaryrefslogtreecommitdiff
path: root/www/webalizer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/webalizer/Makefile')
-rw-r--r--www/webalizer/Makefile36
1 files changed, 18 insertions, 18 deletions
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 04fe566b1680..852ac9b8674b 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -6,34 +6,36 @@
#
PORTNAME= webalizer
-PORTVERSION= 1.30.4
+PORTVERSION= 2.1.5
CATEGORIES= www
MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/ \
ftp://ftp.lan-ks.de/pub/FreeBSD/distfiles/
-DISTNAME= ${PORTNAME}-1.30-04-src
-EXTRACT_SUFX= .tgz
+DISTNAME= ${PORTNAME}-2.01-05-src
MAINTAINER= dirk.meyer@dinoex.sub.org
LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
+USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-gdlib=${PREFIX}/lib \
+CONFIGURE_ARGS+= --enable-dns \
+ --with-etcdir=${PREFIX}/etc \
+ --with-gdlib=${PREFIX}/lib \
--with-gd=${PREFIX}/include/gd
CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib"
-BIN1= webalizer
MAN1= webalizer.1
DOC1= CHANGES COPYING Copyright INSTALL \
- README country-codes.txt webalizer.LSM
-SUPP_LANG= catalan chinese czech dutch english french \
- german italian korean polish portuguese \
- portuguese_brazil romanian russain slowak \
- spanish swedish
+ README README.FIRST DNS.README country-codes.txt
+SUPP_LANG= catalan chinese czech danish dutch english estonian \
+ finnish french german greek hungarian indonesian \
+ italian korean polish portuguese portuguese_brazil \
+ romanian russain slowak slovene spanish swedish turkish
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src$//}
MAKE_ARGS+= CFLAGS="${CFLAGS}"
.if defined(BATCH)
+# no cosmetique spaces allowed
WEBALIZER_LANG=english
.endif
@@ -42,18 +44,16 @@ CONFIGURE_ARGS+= --with-language=${WEBALIZER_LANG}
.endif
pre-configure:
- @${PERL5} -pi -e "s=/etc=${PREFIX}/etc=" ${WRKSRC}/webalizer.c
.if !defined(WEBALIZER_LANG)
@${ECHO_MSG} "You can customize the language by typing"
-.for i in ${SUPP_LANG}
- @${ECHO_MSG} "make WEBALIZER_LANG=${i}"
-.endfor
+ @${ECHO_MSG} " make WEBALIZER_LANG=<lang>"
+ @${ECHO_MSG} "where <lang> is one of:"
+ @${ECHO_MSG} ${SUPP_LANG}
.endif
do-install:
-.for i in ${BIN1}
- @${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin/${i}
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/webalizer ${PREFIX}/bin
+ ${LN} -sf webalizer ${PREFIX}/bin/webazolver
post-install:
.for i in ${MAN1}
@@ -66,7 +66,7 @@ post-install:
.endfor
.endif
${MKDIR} ${PREFIX}/share/examples/webalizer
-.for i in msfree.gif sample.conf webalizer.gif
+.for i in msfree.png sample.conf webalizer.png
@${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/examples/webalizer/${i}
.endfor
@if [ ! -f ${PREFIX}/etc/webalizer.conf-dist ]; then \