aboutsummaryrefslogtreecommitdiff
path: root/www/xpi-downthemall/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/xpi-downthemall/Makefile')
-rw-r--r--www/xpi-downthemall/Makefile56
1 files changed, 17 insertions, 39 deletions
diff --git a/www/xpi-downthemall/Makefile b/www/xpi-downthemall/Makefile
index ebee364db21f..4da5be1eb886 100644
--- a/www/xpi-downthemall/Makefile
+++ b/www/xpi-downthemall/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= downthemall
-PORTVERSION= 1.1.4
+PORTVERSION= 1.1.7
DISTVERSIONSUFFIX= -fx+tb+sm
CATEGORIES= www
@@ -15,47 +15,25 @@ COMMENT= Lets you download all the links in a webpage and much more
XPI_DISTNAME= downthemall!
WRKSRC= ${WRKDIR}/${DISTNAME:S/!/_/}
-XPI_ID= {DDC359D1-844A-42a7-9AA1-88A850A938A8}
-XPI_NUM= 201
-USE_XPI= firefox3
-XPI_FILES= components/migrationService.js \
- components/debugService.xpt \
- components/debugService.js \
+XPI_ID= {DDC359D1-844A-42a7-9AA1-88A850A938A8}
+XPI_FILES= GPL LGPL LICENSE MPL chrome/chrome.jar \
+ chrome/icons/default/DownThemAll.ico \
+ chrome/icons/default/DownThemAll.xpm \
+ chrome.manifest components/contentHandling.js \
components/contenthandling.idl \
- components/filterManager.idl \
components/contenthandling.xpt \
- components/privacycontrol.js \
- components/contentHandling.js \
- components/filterManager.xpt \
- components/filterManager.js \
- components/debugService.idl \
- LICENSE \
- GPL \
- install.rdf \
- defaults/preferences/dta.js \
- defaults/preferences/filters.js \
- defaults/preferences/privacycontrol.js \
- modules/preferences.jsm \
- modules/cothread.jsm \
- modules/utils.jsm \
- modules/mediator.jsm \
- modules/prompts.jsm \
- modules/version.jsm \
- MPL \
- chrome/icons/default/DownThemAll.xpm \
- chrome/icons/default/DownThemAll.ico \
- chrome/chrome.jar \
- chrome.manifest \
- LGPL
-
-XPI_DIRS= components \
- defaults/preferences \
- defaults \
- modules \
- chrome/icons/default \
- chrome/icons \
- chrome
+ components/debugService.idl components/debugService.js \
+ components/debugService.xpt components/filterManager.idl \
+ components/filterManager.js components/filterManager.xpt \
+ components/migrationService.js components/privacycontrol.js \
+ defaults/preferences/dta.js defaults/preferences/filters.js \
+ defaults/preferences/privacycontrol.js install.rdf \
+ modules/cothread.jsm modules/mediator.jsm \
+ modules/preallocator.jsm modules/preferences.jsm \
+ modules/prompts.jsm modules/utils.jsm modules/version.jsm
+XPI_DIRS= chrome/icons/default chrome/icons chrome components \
+ defaults/preferences defaults modules
post-extract:
@${FIND} ${WRKSRC} -name .svn|${XARGS} ${RM} -rf