aboutsummaryrefslogtreecommitdiff
path: root/www/xpi-imagezoom/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/xpi-imagezoom/Makefile')
-rw-r--r--www/xpi-imagezoom/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/www/xpi-imagezoom/Makefile b/www/xpi-imagezoom/Makefile
index 28945bac5513..33e9334c2d01 100644
--- a/www/xpi-imagezoom/Makefile
+++ b/www/xpi-imagezoom/Makefile
@@ -6,19 +6,23 @@
#
PORTNAME= imagezoom
-PORTVERSION= 0.3
+PORTVERSION= 0.3.1
+DISTVERSIONSUFFIX= -fx+mz+tb+sm
CATEGORIES= www
-MASTER_SITES= http://imagezoom.yellowgorilla.net/ CENKES
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+DISTNAME= image_zoom-${PORTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= triosoft@triosoft.com.ua
COMMENT= Zoom images
-CONFLICTS= xpi-imagezoom-ru-[0-9]*
XPI_ID= {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}
+XPI_NUM= 139
XPI_FILES= chrome/imagezoom.jar defaults/preferences/imagezoom-defaults.js \
gpl.txt chrome.manifest install.js install.rdf
XPI_DIRS= chrome defaults/preferences defaults
+post-patch:
+ @${REINPLACE_CMD} -e '/maxVersion/s|3.0b4|3.0.\*|' ${WRKSRC}/install.rdf
+ @${RM} -f ${WRKSRC}/install.rdf.bak
+
.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
.include <bsd.port.mk>