aboutsummaryrefslogtreecommitdiff
path: root/www/zope/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/zope/Makefile')
-rw-r--r--www/zope/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/zope/Makefile b/www/zope/Makefile
index 17fdff1d597f..2b6c9a615d60 100644
--- a/www/zope/Makefile
+++ b/www/zope/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_xmlplus/sax/ex
USE_PYTHON= yes
USE_RC_SUBR= yes
+USE_REINPLACE= yes
DIST_SUBDIR= zope
# Note: the notes that follow reflect the decisions of prior maintainers
@@ -61,6 +62,10 @@ ISBATCH= -u admin:test123
ISBATCH= ""
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\)\(.*"\)$$,\1 2.3.4 \2,g' \
+ ${WRKSRC}/configure
+
post-install:
@${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in ${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
@${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} pkg-message