aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/rubygem-actionpack/Makefile3
-rw-r--r--www/rubygem-activeresource/Makefile3
-rw-r--r--www/rubygem-amazon-ecs/Makefile3
-rw-r--r--www/rubygem-erubis/Makefile3
-rw-r--r--www/rubygem-htauth/Makefile3
-rw-r--r--www/rubygem-httparty/Makefile3
-rw-r--r--www/rubygem-maruku/Makefile3
-rw-r--r--www/rubygem-mechanize/Makefile3
-rw-r--r--www/rubygem-mongrel/Makefile3
-rw-r--r--www/rubygem-mongrel_cluster/Makefile3
-rw-r--r--www/rubygem-rails-app-installer/Makefile3
-rw-r--r--www/rubygem-rails/Makefile3
-rw-r--r--www/rubygem-rfacebook/Makefile3
-rw-r--r--www/rubygem-rubyfulsoup/Makefile6
-rw-r--r--www/rubygem-sinatra/Makefile1
-rw-r--r--www/rubygem-thin/Makefile3
16 files changed, 17 insertions, 32 deletions
diff --git a/www/rubygem-actionpack/Makefile b/www/rubygem-actionpack/Makefile
index 3ecff66d5231..f465e206bcdc 100644
--- a/www/rubygem-actionpack/Makefile
+++ b/www/rubygem-actionpack/Makefile
@@ -12,9 +12,8 @@ MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Action Controller and Action View of Rails MVC Framework
-BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport \
+RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport \
rubygem-rack>=1.1.0:${PORTSDIR}/www/rubygem-rack
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-activeresource/Makefile b/www/rubygem-activeresource/Makefile
index af397648ac5e..96f5aa51fecb 100644
--- a/www/rubygem-activeresource/Makefile
+++ b/www/rubygem-activeresource/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= A coherent wrapper object-relational mapping for REST web services
-BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-amazon-ecs/Makefile b/www/rubygem-amazon-ecs/Makefile
index 078b1d79e6f7..ec5fcba481d0 100644
--- a/www/rubygem-amazon-ecs/Makefile
+++ b/www/rubygem-amazon-ecs/Makefile
@@ -13,9 +13,8 @@ MASTER_SITES= RG
MAINTAINER= tota@FreeBSD.org
COMMENT= A generic Amazon E-commerce REST API written in Ruby
-BUILD_DEPENDS= rubygem-hpricot>=0.4:${PORTSDIR}/www/rubygem-hpricot \
+RUN_DEPENDS= rubygem-hpricot>=0.4:${PORTSDIR}/www/rubygem-hpricot \
${RUBY_PKGNAMEPREFIX}hmac>=0.3.2:${PORTSDIR}/security/ruby-hmac
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-erubis/Makefile b/www/rubygem-erubis/Makefile
index bb233f90fbbf..c3e10ae258f8 100644
--- a/www/rubygem-erubis/Makefile
+++ b/www/rubygem-erubis/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= RG
MAINTAINER= clsung@freebsd.org
COMMENT= A fast, secure, and very extensible implementation of eRuby
-BUILD_DEPENDS= rubygem-abstract>=1.0.0:${PORTSDIR}/devel/rubygem-abstract
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= rubygem-abstract>=1.0.0:${PORTSDIR}/devel/rubygem-abstract
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-htauth/Makefile b/www/rubygem-htauth/Makefile
index e39c2a516326..4311356ed7a0 100644
--- a/www/rubygem-htauth/Makefile
+++ b/www/rubygem-htauth/Makefile
@@ -13,8 +13,7 @@ MASTER_SITE_SUBDIR= copiousfreetime
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Replacement for the Apache htdigest and htpasswd
-BUILD_DEPENDS= rubygem-highline>=1.5.0:${PORTSDIR}/devel/rubygem-highline
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= rubygem-highline>=1.5.0:${PORTSDIR}/devel/rubygem-highline
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-httparty/Makefile b/www/rubygem-httparty/Makefile
index 198feab44b4e..24fcae878652 100644
--- a/www/rubygem-httparty/Makefile
+++ b/www/rubygem-httparty/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= RF
MAINTAINER= wen@FreeBSD.org
COMMENT= Ruby Library that Makes HTTP Fun Again
-BUILD_DEPENDS= rubygem-crack>=0.1.1:${PORTSDIR}/devel/rubygem-crack
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= rubygem-crack>=0.1.1:${PORTSDIR}/devel/rubygem-crack
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-maruku/Makefile b/www/rubygem-maruku/Makefile
index 33458e27caa6..e66c0228c152 100644
--- a/www/rubygem-maruku/Makefile
+++ b/www/rubygem-maruku/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= RG
MAINTAINER= avl@FreeBSD.org
COMMENT= A Markdown and PHP Markdown extra interpreter for Ruby
-BUILD_DEPENDS= rubygem-syntax>=1.0.0:${PORTSDIR}/textproc/rubygem-syntax
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= rubygem-syntax>=1.0.0:${PORTSDIR}/textproc/rubygem-syntax
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-mechanize/Makefile b/www/rubygem-mechanize/Makefile
index 4a0fb7f19aab..eec6fdd7c9c6 100644
--- a/www/rubygem-mechanize/Makefile
+++ b/www/rubygem-mechanize/Makefile
@@ -12,10 +12,9 @@ MASTER_SITES= RG
MAINTAINER= clsung@FreeBSD.org
COMMENT= WWW::Mechanize, a handy web browsing ruby object
-BUILD_DEPENDS= rubygem-hpricot>=0.5.0:${PORTSDIR}/www/rubygem-hpricot \
+RUN_DEPENDS= rubygem-hpricot>=0.5.0:${PORTSDIR}/www/rubygem-hpricot \
rubygem-hoe>=1.5.0:${PORTSDIR}/devel/rubygem-hoe \
rubygem-nokogiri>=1.2.1:${PORTSDIR}/textproc/rubygem-nokogiri
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-mongrel/Makefile b/www/rubygem-mongrel/Makefile
index d5ad6726368f..1059e0253c09 100644
--- a/www/rubygem-mongrel/Makefile
+++ b/www/rubygem-mongrel/Makefile
@@ -13,10 +13,9 @@ DISTFILES= ${PATCHNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= clsung@FreeBSD.org
COMMENT= Fast HTTP 1.1 library and server for Ruby web applications
-BUILD_DEPENDS= gpgen:${PORTSDIR}/devel/rubygem-gem_plugin \
+RUN_DEPENDS= gpgen:${PORTSDIR}/devel/rubygem-gem_plugin \
rubygem-daemons>=1.0.3:${PORTSDIR}/devel/rubygem-daemons \
rubygem-fastthread>=1.0.1:${PORTSDIR}/devel/rubygem-fastthread
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-mongrel_cluster/Makefile b/www/rubygem-mongrel_cluster/Makefile
index 9b838439a534..99e4612b2468 100644
--- a/www/rubygem-mongrel_cluster/Makefile
+++ b/www/rubygem-mongrel_cluster/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= mongrel
MAINTAINER= avl@FreeBSD.org
COMMENT= Manages multiple Mongrel processes
-BUILD_DEPENDS= rubygem-mongrel>=1.0.2:${PORTSDIR}/www/rubygem-mongrel
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= rubygem-mongrel>=1.0.2:${PORTSDIR}/www/rubygem-mongrel
USE_RC_SUBR= mongrel_cluster
USE_RUBY= yes
diff --git a/www/rubygem-rails-app-installer/Makefile b/www/rubygem-rails-app-installer/Makefile
index 84b563af0dca..25374e40fc8b 100644
--- a/www/rubygem-rails-app-installer/Makefile
+++ b/www/rubygem-rails-app-installer/Makefile
@@ -14,10 +14,9 @@ MASTER_SITE_SUBDIR= rails-installer
MAINTAINER= geraud@gcu.info
COMMENT= An installer for Rails apps
-BUILD_DEPENDS= rubygem-sqlite3>=1.1.0:${PORTSDIR}/databases/rubygem-sqlite3 \
+RUN_DEPENDS= rubygem-sqlite3>=1.1.0:${PORTSDIR}/databases/rubygem-sqlite3 \
rubygem-mongrel>=0.3.13:${PORTSDIR}/www/rubygem-mongrel \
rubygem-mongrel_cluster>=0.2.0:${PORTSDIR}/www/rubygem-mongrel_cluster
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RAKE= yes
diff --git a/www/rubygem-rails/Makefile b/www/rubygem-rails/Makefile
index b87c972de044..0f05b55212a4 100644
--- a/www/rubygem-rails/Makefile
+++ b/www/rubygem-rails/Makefile
@@ -12,12 +12,11 @@ MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= MVC web application framework
-BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport \
+RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-${PORTVERSION}.gemspec:${PORTSDIR}/devel/rubygem-activesupport \
${LOCALBASE}/${SPEC_DIR}/activerecord-${PORTVERSION}.gemspec:${PORTSDIR}/databases/rubygem-activerecord \
${LOCALBASE}/${SPEC_DIR}/actionpack-${PORTVERSION}.gemspec:${PORTSDIR}/www/rubygem-actionpack \
${LOCALBASE}/${SPEC_DIR}/actionmailer-${PORTVERSION}.gemspec:${PORTSDIR}/mail/rubygem-actionmailer \
${LOCALBASE}/${SPEC_DIR}/activeresource-${PORTVERSION}.gemspec:${PORTSDIR}/www/rubygem-activeresource
-RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS= FCGI "FastCGI support" Off\
MEMCACHE_CLIENT "MemCache-Client support" Off
diff --git a/www/rubygem-rfacebook/Makefile b/www/rubygem-rfacebook/Makefile
index 5a4331896a8c..355a3003edf7 100644
--- a/www/rubygem-rfacebook/Makefile
+++ b/www/rubygem-rfacebook/Makefile
@@ -13,9 +13,8 @@ MASTER_SITES= RG
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Ruby interface to the Facebook API
-BUILD_DEPENDS= rubygem-hpricot>=0.6:${PORTSDIR}/www/rubygem-hpricot \
+RUN_DEPENDS= rubygem-hpricot>=0.6:${PORTSDIR}/www/rubygem-hpricot \
rubygem-mocha>=0.5.3:${PORTSDIR}/devel/rubygem-mocha
-RUN_DEPENDS= ${BUILD_REQUIRES}
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/rubygem-rubyfulsoup/Makefile b/www/rubygem-rubyfulsoup/Makefile
index cc2f16affe74..824f8fef8c98 100644
--- a/www/rubygem-rubyfulsoup/Makefile
+++ b/www/rubygem-rubyfulsoup/Makefile
@@ -13,12 +13,12 @@ DISTNAME= rubyful_soup-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Ruby port of the HTML/XML parser Beautiful Soup
-BUILD_DEPENDS= rubygem-htmltools>=1.10:${PORTSDIR}/textproc/rubygem-htmltools
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= rubygem-htmltools>=1.10:${PORTSDIR}/textproc/rubygem-htmltools
+
+GEM_NAME= ${DISTNAME}
USE_RUBY= yes
USE_RUBYGEMS= yes
-GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/www/rubygem-sinatra/Makefile b/www/rubygem-sinatra/Makefile
index 179c8b8c8571..3bc481605bcb 100644
--- a/www/rubygem-sinatra/Makefile
+++ b/www/rubygem-sinatra/Makefile
@@ -12,7 +12,6 @@ MASTER_SITES= RG
MAINTAINER= daniel@roe.ch
COMMENT= A classy web development framework in ruby
-BUILD_DEPENDS= rubygem-rack>=0.9.1:${PORTSDIR}/www/rubygem-rack
RUN_DEPENDS= rubygem-rack>=0.9.1:${PORTSDIR}/www/rubygem-rack
USE_RUBY= yes
diff --git a/www/rubygem-thin/Makefile b/www/rubygem-thin/Makefile
index c230e2ba9549..3e9bc22b6d22 100644
--- a/www/rubygem-thin/Makefile
+++ b/www/rubygem-thin/Makefile
@@ -12,10 +12,9 @@ MASTER_SITES= RG
MAINTAINER= clsung@FreeBSD.org
COMMENT= A fast and very simple Ruby web server
-BUILD_DEPENDS= rubygem-rack>=1.0.0:${PORTSDIR}/www/rubygem-rack \
+RUN_DEPENDS= rubygem-rack>=1.0.0:${PORTSDIR}/www/rubygem-rack \
rubygem-eventmachine>=0.8.1:${PORTSDIR}/devel/rubygem-eventmachine \
rubygem-daemons>=1.0.9:${PORTSDIR}/devel/rubygem-daemons
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes