aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_tsunami/Makefile27
-rw-r--r--www/mod_tsunami/distinfo1
-rw-r--r--www/mod_tsunami/pkg-comment1
-rw-r--r--www/mod_tsunami/pkg-descr6
-rw-r--r--www/mod_tsunami/pkg-plist3
6 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 533375f0099c..904575129583 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -135,6 +135,7 @@
SUBDIR += mod_snake
SUBDIR += mod_throttle
SUBDIR += mod_ticket
+ SUBDIR += mod_tsunami
SUBDIR += mod_zap
SUBDIR += momspider
SUBDIR += mozilla
diff --git a/www/mod_tsunami/Makefile b/www/mod_tsunami/Makefile
new file mode 100644
index 000000000000..24ffcdb854ef
--- /dev/null
+++ b/www/mod_tsunami/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mod_tsunami
+# Date created: 10 April 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_tsunami
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mod-tsunami
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_tsunami/distinfo b/www/mod_tsunami/distinfo
new file mode 100644
index 000000000000..6dc0e0a0ed6d
--- /dev/null
+++ b/www/mod_tsunami/distinfo
@@ -0,0 +1 @@
+MD5 (mod_tsunami-1.0.tar.gz) = cb37c43cf19db0186abf7870eb9ed335
diff --git a/www/mod_tsunami/pkg-comment b/www/mod_tsunami/pkg-comment
new file mode 100644
index 000000000000..b8eb04710ae3
--- /dev/null
+++ b/www/mod_tsunami/pkg-comment
@@ -0,0 +1 @@
+Apache module which dynamically limits a site's slot usage
diff --git a/www/mod_tsunami/pkg-descr b/www/mod_tsunami/pkg-descr
new file mode 100644
index 000000000000..c6b5b115d40a
--- /dev/null
+++ b/www/mod_tsunami/pkg-descr
@@ -0,0 +1,6 @@
+mod_tsunami is an apache module which dynamically limits
+the number of httpd slots used per main web directories.
+It is useful if you provide home pages hosting, and don't
+want one site to use all the resources.
+
+WWW: http://mod-tsunami.sourceforge.net/
diff --git a/www/mod_tsunami/pkg-plist b/www/mod_tsunami/pkg-plist
new file mode 100644
index 000000000000..fb97495c59b3
--- /dev/null
+++ b/www/mod_tsunami/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_tsunami.so
+@exec %D/sbin/apxs -e -A -n tsunami %D/%F
+@unexec %D/sbin/apxs -e -A -n tsunami %D/%F