aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-Struct/Makefile3
-rw-r--r--www/p5-Catalyst-Authentication-Store-DBIx-Class/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-CookiedSession/Makefile3
-rw-r--r--www/p5-Dancer-Logger-Log4perl/Makefile3
-rw-r--r--www/p5-Dancer-Plugin-ValidationClass/Makefile3
-rw-r--r--www/p5-HTML-Defaultify/Makefile3
-rw-r--r--www/p5-HTML-Selector-XPath/Makefile3
-rw-r--r--www/p5-HTTP-Session/Makefile3
-rw-r--r--www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile3
-rw-r--r--www/p5-POEx-Role-PSGIServer/Makefile3
-rw-r--r--www/p5-Perlbal-Plugin-PSGI/Makefile3
-rw-r--r--www/p5-Plack-App-Proxy/Makefile3
-rw-r--r--www/p5-Plack-Middleware-Expires/Makefile3
-rw-r--r--www/p5-Template-Mustache/Makefile3
-rw-r--r--www/p5-WWW-Mixi/Makefile3
-rw-r--r--www/p5-WWW-RobotRules-Parser/Makefile3
-rw-r--r--www/p5-WWW-Scraper-ISBN-ORA_Driver/Makefile3
-rw-r--r--www/p5-WWW-Tumblr/Makefile3
-rw-r--r--www/twiki/Makefile2
19 files changed, 37 insertions, 19 deletions
diff --git a/www/p5-CGI-Struct/Makefile b/www/p5-CGI-Struct/Makefile
index bb04027beb62..b49cb0bbdcac 100644
--- a/www/p5-CGI-Struct/Makefile
+++ b/www/p5-CGI-Struct/Makefile
@@ -13,7 +13,8 @@ LICENSE= BSD
TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Struct.3
diff --git a/www/p5-Catalyst-Authentication-Store-DBIx-Class/Makefile b/www/p5-Catalyst-Authentication-Store-DBIx-Class/Makefile
index ec84c3240e45..77d106661734 100644
--- a/www/p5-Catalyst-Authentication-Store-DBIx-Class/Makefile
+++ b/www/p5-Catalyst-Authentication-Store-DBIx-Class/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Catalyst-Model-DBIC-Schema>=0.18:${PORTSDIR}/www/p5-Catalyst-M
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Authentication::Realm::SimpleDB.3 \
Catalyst::Authentication::Store::DBIx::Class.3 \
diff --git a/www/p5-Catalyst-Plugin-CookiedSession/Makefile b/www/p5-Catalyst-Plugin-CookiedSession/Makefile
index 076660f2c1fe..fbe8285fb401 100644
--- a/www/p5-Catalyst-Plugin-CookiedSession/Makefile
+++ b/www/p5-Catalyst-Plugin-CookiedSession/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::CookiedSession.3
diff --git a/www/p5-Dancer-Logger-Log4perl/Makefile b/www/p5-Dancer-Logger-Log4perl/Makefile
index 5e5732b7a639..504aae593dad 100644
--- a/www/p5-Dancer-Logger-Log4perl/Makefile
+++ b/www/p5-Dancer-Logger-Log4perl/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Dancer>=1.2001:${PORTSDIR}/www/p5-Dancer \
p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dancer::Logger::Log4perl.3
diff --git a/www/p5-Dancer-Plugin-ValidationClass/Makefile b/www/p5-Dancer-Plugin-ValidationClass/Makefile
index b1fd8a314e32..655af00f0809 100644
--- a/www/p5-Dancer-Plugin-ValidationClass/Makefile
+++ b/www/p5-Dancer-Plugin-ValidationClass/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
p5-Validation-Class>0:${PORTSDIR}/devel/p5-Validation-Class
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dancer::Plugin::ValidationClass.3
diff --git a/www/p5-HTML-Defaultify/Makefile b/www/p5-HTML-Defaultify/Makefile
index 1c30f7053ac5..65d966aac87c 100644
--- a/www/p5-HTML-Defaultify/Makefile
+++ b/www/p5-HTML-Defaultify/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl module to populate HTML forms with default values
RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Defaultify.3
.include <bsd.port.mk>
diff --git a/www/p5-HTML-Selector-XPath/Makefile b/www/p5-HTML-Selector-XPath/Makefile
index ef76b29adcf4..198cba9d7d92 100644
--- a/www/p5-HTML-Selector-XPath/Makefile
+++ b/www/p5-HTML-Selector-XPath/Makefile
@@ -16,7 +16,8 @@ COMMENT= HTML::Selector::XPath - CSS Selector to XPath compiler
TEST_DEPENDS= p5-Test-Base>=0:${PORTSDIR}/devel/p5-Test-Base
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Selector::XPath.3
diff --git a/www/p5-HTTP-Session/Makefile b/www/p5-HTTP-Session/Makefile
index 16f2396ac019..ca7473baade2 100644
--- a/www/p5-HTTP-Session/Makefile
+++ b/www/p5-HTTP-Session/Makefile
@@ -24,7 +24,8 @@ TEST_DEPENDS= \
p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-Memory-Cycle>0:${PORTSDIR}/devel/p5-Test-Memory-Cycle
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Session.3 \
HTTP::Session::State::Cookie.3 \
diff --git a/www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile
index 0314d0d0dc3d..f79bbeed6e74 100644
--- a/www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile
+++ b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= LWP::ConnCache::MaxKeepAliveRequests.3
diff --git a/www/p5-POEx-Role-PSGIServer/Makefile b/www/p5-POEx-Role-PSGIServer/Makefile
index d9d7db4e41ef..8e1f76f30f99 100644
--- a/www/p5-POEx-Role-PSGIServer/Makefile
+++ b/www/p5-POEx-Role-PSGIServer/Makefile
@@ -34,7 +34,8 @@ TEST_DEPENDS= p5-HTTP-Parser-XS>=0:${PORTSDIR}/www/p5-HTTP-Parser-XS \
p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-TCP>=0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POEx::Role::PSGIServer.3 \
POEx::Role::PSGIServer::ProxyWriter.3 \
diff --git a/www/p5-Perlbal-Plugin-PSGI/Makefile b/www/p5-Perlbal-Plugin-PSGI/Makefile
index 4490601d3f54..6a2effb88ef4 100644
--- a/www/p5-Perlbal-Plugin-PSGI/Makefile
+++ b/www/p5-Perlbal-Plugin-PSGI/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-TCP>=0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Perlbal::Plugin::PSGI.3
diff --git a/www/p5-Plack-App-Proxy/Makefile b/www/p5-Plack-App-Proxy/Makefile
index 6659e62014e0..77f5f0e92aa5 100644
--- a/www/p5-Plack-App-Proxy/Makefile
+++ b/www/p5-Plack-App-Proxy/Makefile
@@ -19,7 +19,8 @@ TEST_DEPENDS= \
p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::App::Proxy.3 \
Plack::App::Proxy::Backend.3 \
diff --git a/www/p5-Plack-Middleware-Expires/Makefile b/www/p5-Plack-Middleware-Expires/Makefile
index b16cb7c2325d..3b0a4b14eb69 100644
--- a/www/p5-Plack-Middleware-Expires/Makefile
+++ b/www/p5-Plack-Middleware-Expires/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-Plack>=0.9937:${PORTSDIR}/www/p5-Plack \
p5-Try-Tiny>=0.06:${PORTSDIR}/lang/p5-Try-Tiny \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::Expires.3
diff --git a/www/p5-Template-Mustache/Makefile b/www/p5-Template-Mustache/Makefile
index 67d2fc1ba65c..f31f2d46f5a0 100644
--- a/www/p5-Template-Mustache/Makefile
+++ b/www/p5-Template-Mustache/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-YAML-Syck>=1.15:${PORTSDIR}/textproc/p5-YAML-Syck
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS:= p5-Test-Mini-Unit>=v1.0.3:${PORTSDIR}/devel/p5-Test-Mini-Unit
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Mustache.3
diff --git a/www/p5-WWW-Mixi/Makefile b/www/p5-WWW-Mixi/Makefile
index 768b07eaabb4..a0c61851926f 100644
--- a/www/p5-WWW-Mixi/Makefile
+++ b/www/p5-WWW-Mixi/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
ja-p5-Jcode>=0:${PORTSDIR}/japanese/p5-Jcode
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Mixi.3 WWW::Mixi::Cookbook.3 WWW::Mixi::Mixi.3
diff --git a/www/p5-WWW-RobotRules-Parser/Makefile b/www/p5-WWW-RobotRules-Parser/Makefile
index 8d5a5e4165cb..369542b6a078 100644
--- a/www/p5-WWW-RobotRules-Parser/Makefile
+++ b/www/p5-WWW-RobotRules-Parser/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-URI>=0:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::RobotRules::Parser.3
diff --git a/www/p5-WWW-Scraper-ISBN-ORA_Driver/Makefile b/www/p5-WWW-Scraper-ISBN-ORA_Driver/Makefile
index b765f84da8fc..858220b77862 100644
--- a/www/p5-WWW-Scraper-ISBN-ORA_Driver/Makefile
+++ b/www/p5-WWW-Scraper-ISBN-ORA_Driver/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= p5-Template-Extract>=0:${PORTSDIR}/textproc/p5-Template-Extract \
p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
p5-WWW-Scraper-ISBN-Driver>=0.18:${PORTSDIR}/www/p5-WWW-Scraper-ISBN-Driver
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Scraper::ISBN::ORA_Driver.3
diff --git a/www/p5-WWW-Tumblr/Makefile b/www/p5-WWW-Tumblr/Makefile
index b07173ca8497..4d0b89e32707 100644
--- a/www/p5-WWW-Tumblr/Makefile
+++ b/www/p5-WWW-Tumblr/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Tumblr.3
diff --git a/www/twiki/Makefile b/www/twiki/Makefile
index db080e9b9995..3139996b0197 100644
--- a/www/twiki/Makefile
+++ b/www/twiki/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
twiki-TWikiUserMappingContrib>=0:${PORTSDIR}/www/twiki-TWikiUserMappingContrib
-USE_PERL5= yes
+USES= perl5
WRKSRC= ${WRKDIR}/twiki
post-extract: